Windows 10 Does not load after Manjaro Installation

Hi. So, I decided to install Manjaro KDE alongside my Windows 10 and did exactly what this topic said.
And I typed efibootmgr on my Terminal (Live Manjaro) and I found out that my Manjaro is the second.
So as @gohlip mentioned I typed the following commands (sda8 my boot media and sda10 my root media)

sudo mount /dev/sda10 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
sudo cp /mnt/boot/grub/x86_64-efi/core.efi /mnt/boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

And when I typed efibootmgr I got the same result
So after a reboot I saw the error: "No bootable media found" (So I'm not sure but I might have used mount /dev/sda8 /mnt as well)
I re-inserted the USB again and booted the live OS and tried to re-install grub as this topic mentions.

I got the "EFI variables are not supported on this system." error so I did the following:
pacman -S efibootmgr dosftools grub
yet the same error so I went chroot and did:
mount -t efivarfs efivarfs /sys/firmware/efi/efivars
(I executed the command before it in non-chroot)
So now I get "mount point does not exist" for that path.

I also tried the alternate route and I get "efibootmgr failed to register the boot entry: No such file or directory."

Can someone help me with this? I'm currently without access to both Windows 10 and non-Live Manjaro.

btw, will deleting Manjaro boot partition and the OS save my Windows?

Since you've installed to disk, use

this post to get your grub working.

Hey man, thanks for your reply.
Before I could use the boot command it loaded and I chose Manjari KDE but it's stuck on the loading screen after I typed username and password.

Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).

I pressed 'c' and then used the grub commands as instructed (search.file and configfile)
Before I could type 'boot' it loaded grub and there was Manjaro, Advanced options for Manjaro, Memory test
So I chose the first
Typed the password I chose during setup
Now it's stuck on the screen

EDIT: Still stuck as we speak, might need to use the power key on my laptop

Ok, looks your install is okay then.
You need to then boot to prompt and fix things in prompt.

After getting to configfike grub menu, from grub prompt, edit that entry, by pressing 'e' this time.
Arrow down to linux line and add '3' (no apostrophes) after the 'rw' . Press F10 to boot.

You will get to prompt, log in with password
sudo pacman-mirrors -f5
sudu pacman -Syyuu

Fix graphic drivers (mhwd)
Don't forget to fix grub as per my link.

Let us know if you can boot to prompt.
Late here, will log off soon.
If you can boot to prompt ( most likely), others can help you with the rest to fix graphics.

And again, Don't forget to fix grub.

you mean type mhwd?

Error: failed retrieving file multilib.db

error from all mirrors

Now the sudo pacman -S grub-vanilla removed grub and gave the same error for grub-vanilla package. So I reinstalled grub untill further instructions

Update: So now I reinstalled Manjaro.
Now the login page appears (no grub) and I type password but it freezes like that state.

Is this progress or downgrade?

My interpertation is that grub is there but does not load automitically.

Since this was no help, I'm waiting for instructions on how to fix this when the mirrors return error as well
And, my sda is turned into sdb, I messed up big time I guess

Is the GPT recorvery record I made a few days ago using BIOS gonna help?

You have no internet access. That is all.
And that's why you cannot update mirrors (pacman-mirrors or pacman -Syyuu).
And you still have this graphic driver issue.

Well, I have my Live Linux no longer loading as well, I can use the grub command-line though

The best thing to do here I think is to reinstall my Windows 10, then Install the later version of Manjaro and use Windows cmd so that one command will not make this messes up anymore. I think I installed grub in the wrong sda causing my Windows boot loader to take damage

Probably the best, in your case.
Good luck. Take care.

Yep, thanks for your time anyways.
I will post again if I was stuck after re-doing all of it on a better time, currently I seriously need my Windows back

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by