Windows 10 EFI Dual Boot: Boot directly to windows


I've tried to install Manjaro on my Xiaomi Notebook Pro using that post :

[wiki] Windows 10 - Manjaro - Dual-boot - Step by Step

So I've used disc clean up on windows, shrank my partition.
On the liveCD I've created my 3 partition: /efi/boot, swap and /
efitbootmgr didn't display Manjaro in the list so I followed those instructions in the topic : [HowTo] Dual-boot Manjaro - Windows 10 - Step by Step and Manjaro appeared on top, yeeaah!
But my computer directly boot to windows :frowning:

next step :

    Run CMD as Administrator
    bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi

But again I boot on windows directly :confused:
The grub itself has no problem, I can boot from it using the Manjaro liveUsb.

I have no idea what to do now :confused:
Sorry to create a new topic, I couldn't reply to the one I used, I don't know why.

Hi, I received a notification to this post (I don't know why) but using windows bcd is something I don't do at all. Hopefully @AgentS or others can help if you want to to proceed with this method.

You can read up about the linux method I recommend here if you want to and I'll be happy to go through if you want to use this approach.

Oh, being new to this forum, there may be a initial limit to your replies and number of responses you can make, to prevent spam and other stuff.

And ζ¬’θΏŽγ€‚(welcome)

It look like you have 2 efi partitions one is the windows we can call it dev/sdaXwhile you did create a new efi partition to manjaro in another what we can call dev/sdbY so when you did see efibootmgr you probably did only see the partition dev/sdbY where always manjaro would be in top. You can try look into the boot options of your MB (Bios) and see if there is 2 options Windows boot manager and Manjaro if you see manjaro you can select this option what would leave you jump into manjaro (if you did a right UEFI instalation not MBR is alot of ppl what fail in this step when they start with this). If you could go into manjaro you should run efibootmgr to see if you have the Windows Boot manager added (if not you should reinstall or update the grub) if you can see what this entry is added just would be enough with fix how first option to load in your Bios the entrie of Manjaro.

It is just what i can imagine out what is happening with your instalation if how said you did a right efi instalation.

1 Like

@gohlip: that link is a bit difficult to understand, I'll take my time to read all of that and come back to you later ^^

@XtyM: Right now I have two windows entry in my bios

Did you set in UEFI to start from Manjaro EFI partition? In some firmwares you must specify such boot manually and sometimes even give a proper path to boot file.

In my experience, in many systems installing Manjaro in UEFI mode isn't enough, UEFI must be set for Manjaro, otherwise system will still use default Windows one, which doesn't include Manjaro, while Manjaro will have itself plus Windows.

i installed manjaro (first linux based system) yesterday and ran into some of the same problems.

mistakes i made:

  • i created a separate /boot/efi fat32 partition even tho win10 already created one.
  • installed manjaro in legacy mode (?) because i didn't boot the usb stick from UEFI only.

i used this guide step by step afterwards and everything worked perfectly:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by