Windows 10 - Update 1809 breaking grub

My personal laptop runs Manjaro and Windows 10 with an UEFI setup. I've installed update 1089 and something messed my grub . The partition table was somehow damaged, I have a dell inspiron 15 and dell auto repair kicked in, what I assume to be an error with windows boot after grub managed to be a problem in uefi itself. I'm burning an iso to repair grub now.

Windows messing up GRUB? That's a rarity! :rofl:

1 Like

Hi @jonathon well I'm havign another issue when booting the live cd so I can chroot. It reports invalid arch-independent ELF magic.

1 Like

Invalid magic is the worst kind.

Are you using a 64-bit image with a 64-bit installation?

Did you verify the image checksum or signature?


Yes to both. Using manjaro-kde-18.0.2-s=x86_64stable

Just checked that the download was made from:
And the hashes do match. @ am here and Im pissed I will check it tommorow.

Yeah, Microsoft is so into Linux nowadays. Strange that they do this.

1 Like

Try this
No chroot required. The [Simple First Start] will do. Just make sure you start computer in uefi mode.


I think my grub did get messed up. Still the manjaro pendrive is not working :confused:

You need to get your livecd (liveusb) working to get to fix your OS.
Your grub may be messed up, that's okay, we can fix that.
But to fix it, we need a working liveusb.

But can you get to a grub menu or a grub prompt? (from your computer system?)
grub rescue prompt maybe? Though that is not as good.

1 Like

I'm still stuck I did some steps back. I'm using the manjaro architech iso but it wont boot. At the moment I have UEFI with secure boot off. Still I get the invalid magic number issue. If I disable secure boot I can again get back to my windows at least. Any ideas? I' ve creatd the USB disk with the following command:
sudo dd bs=4M if=/home/fjefoeojfio/Downloads/manjaro-kde-18.0.2-stable-x86_64.iso of=/dev/sdc1 status=progress

kde iso is fine. You will need to start up liveusb created with secure boot off and in uefi. You do not need to boot to liveOS, just use the liveusb boot menu and go to grub prompt and carry on from there to boot to the installed manjaro OS in your system.

I need clarification on your last post. Can you boot windows after the windows update?

1 Like

By disabling UEFI boot I can get to windows else I get the magic number error.
My current config is here:

Clarify again please, this time more important.
Are you saying you can only boot Windows with

  1. Legacy Boot Mode, Secure Boot OFF

You cannot boot Windows with

  1. UEFI Boot Mode, Secure Boot ON

Confirm please.

1 Like

Yes. Okay I'm all operational again. The trick was to use etcher to burn the iso. With that I booted my old systems and ran:
##################### Simple First Start ########################

  1. boot up livecd in the right mode, uefi or bios-legacy
  2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg
  1. When booted
sudo grub-install /dev/sda
sudo update-grub
  1. Done.

for you :slight_smile:


to use the proper command

The target you used was a partition. It should be the drive (/dev/sdc).
But Etcher does the same and with a GUI!! :wink:



1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by