Windows 10 upgrade removed dual boot

select 1 if only one line

1 Like

I can see that. But how come @antouank has been able to choose Manjaro's bootloader from the live usb's boot screen to boot into their proper installation? That to me implies that the bootloader is intact and doesn't need re-installation.

In this case perhaps reordering the boot order with the command
sudo efibootmgr -o xxxx,yyyy,zzzz
could have done the job.

1 Like

bingo!
that worked.

thank you all so much.

bonus questions :slight_smile:

  • do I need that p7 partition? Or can I delete it?
  • I see some old things like antergos ( I had it before manjaro ). Can I clean those up somehow?
1 Like

you can remove /boot/efi /(lists) in p7
better is to remove or format p7 , dont keep boot & esp flag on this

you been chrooted !

can I remove the partition altogether?

yes you can remove this p7 partition

1 Like

b-w-s-sgs

1 Like

Morning, everybody. I see that's fixed but has generated some confusion.
So some clarification is in order.

First, an entry appearing in efibootmgr does not mean it is bootable or even the efi file is there.
For example, OP's 'antergos' entry is there but we are quite sure it won't boot. Similarly we have a 'manjaro' entry before we all get to work on solving this. That won't boot either if windows update truly overrides the linux boot (but reminder, entries of all in efibootmgr will still be there).
Entries in efibootmgr are entries in the bios (uefi) firmware, that's all that is.

Second, after chrooting and changing fstab entry and doing a 'grub-install' command, the efibootmgr manjaro entry will be changed (and point to) the new manjaro location (boot/efi partition) and the efi file (grubx64.efi). So reordering the bootorder after these were done will boot manjaro.

Using this method to fix bootloader is easier, faster and safer and cause less confusion. To recall, there is no need to change fstab /boot/efi entry (unless it is no longer there - unlikely windows just change uuid, it is not debian).

As to whether we can remove some entries and some efi files; yes, we can do that, though it is unnecessary, just some cleaning up. 'antergos' can be cleaned up, for example without issue. But we have to be careful that we do not remove working efi entries and files.

As usual, it is better to have a new complete picture since things and partitions are changed.
So we do not have to change anything now, but if we want, as per the link, the output of some things are needed.

efibootmgr -v
sudo parted -l
sudo blkid
cat /etc/fstab

Another useful command to reset firmware entries is
sudo mount -o remount,rw /sys/firmware/efi/efivars
but don't do this if we are not clear.

Cheers. Back to my morning routine. Take care.

4 Likes

thanks for the explanation.

I'll take a step back actually and say as a software engineer and 7+ years user of linux as my daily OS, I'm embarrassed I still don't understand AT ALL how booting works.
MBR, UEFI, grub, whatever, they are always so complicated and difficult to understand that makes it scary to touch.

In my mind, it should be like :

  • you have 4 partitions in your drives. A,B,C,D. cool.
  • you can tell the BIOS to point to partition B for example, for booting.
  • in there there should be something for the OS to load.
    done.

now why do I think it's way more complicated in reality?
not sure.
I've looked at the arch wiki to learn more, I even tried rEFInd to make my booting screen prettier, and I ended up messing things even more apparently ( since I can see booting files of old stuff, etc ).
In general, I'm scared to touch it now. :frowning:

Don't be, I've more than 7 years using linux and I still don't know how X11, wayland, graphics tie in together. Or a bunch of other things, for that matter.

As said earlier, there is no need for you to touch anything now. These are just spring cleaning stuff, if you want to clean up. They take up so little space and no other resource. Don't worry about it.

Cheers, take care.

2 Likes

@gohlip

Thanks for posting and for your explanation!

I do understand that

However, since the OP was able to run the "detect EFI loaders" from the boot screen of the live usb, detected the loader and succeed to boot into their proper, bare metal installation, so I thought that, that would imply the bootloader is intact and the efi file is there. Here is what op said:

Therefore I assumed that that the Manjaro's efi was intact and the entry in the efibootmgr correct and functioning. Thus, reordering the boot order should be able to put Manjaro on top of the "boot chain".

Perhaps I am mistaken and I gladly stand corrected if that is the case.

Good point and you are correct that there is a efi file that boots Manjaro. [1]
But the firmware entry, as shown in 'efibootmgr', may not be the correct one to boot.
As you look into post 3, his output before doing anything, the manjaro entry is

That just point to the partition (partuuid) without pointing to the efi file.
If the OP now prints out 'efibootmgr -v' now, after doing the things he did, it would show the manjaro entry with a grubx64.efi file in it. (maybe he would have 2 manjaro entries). {and with a different partuuid now, since he changed fstab uuid}

@antouank, could you now print out your output of 'efibootmgr -v'?
No worries, it won't do anything and we won't ask you to do anything, unless you want.

Glad you ask these questions.

1 Like

happy to help :slight_smile:

( I did ran sudo efibootmgr -b 0 -B once, to remove that stale "antergos" line )
here you go :

➜  ~ efibootmgr -v    
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0004,0003,0002
Boot0001* manjaro	HD(2,GPT,4ecff3aa-ea2b-4715-8402-936346cf51c5,0x1964800,0x32000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* rEFInd Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* Linux Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0004* Windows Boot Manager	HD(2,GPT,4ecff3aa-ea2b-4715-8402-936346cf51c5,0x1964800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...W................

@Marte

It was... (for comparision).

@antouank, glad that you removed 'antergos'; If you don't use refind, you can also remove 0002 and 0003.

I'd like to make the boot screen prettier, and easy to configure, but yes, I failed miserably :joy:
So I'll remove rEFInd as well like you said.

Thanks :+1:

1 Like

Thnaks! I understand better. One last question, again regarding that "functioning" efi file. Couldn't we use efiboomgr to create a new boot entry pointing to the correct partition containing the file?

Yes. And a very good question too. :clap:

The efibootmgr command...

sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

and is in my link under [Additional UEFI commands] will do just that.

If an existing 'manjaro' entry exists, that will generate a duplicate entry for 'manjaro' with a warning. Which is alright (but we can remove the old manjaro entry, if we want).

Again, happy you ask these questions. It also makes my understanding better.

2 Likes

That's great to know! What a nice learning experience this was!
And thank you for sharing of your knowledge. I really appreciate it.

By the way, I have taken this to my heart: 学习的敌人是自己的满足, now that I am trying (a bit struggling) to learn a new language.

Thanks again!

1 Like

Thanks for the info!
It was nice to take part in this thread, a nice learning experience.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by