Windows Boot option is gone after installing Manjaro

That's what I was thinking. I have the installation drive so I will give this a try and hopefully it works.

I suspect you installed windows in BIOS Legacy mode. You need to reinstall in UEFI to have it recognized by Grub . I suggest you disable SSD during win installation so it doesn't mess $esp entries.

1 Like

I got it going again using the post from above using the install media. As a note to anyone who needs to do this in the future, the last input "bootrec /fixboot" failed with don't have permission so I exited and ran the repair option again and it automatically fixed itself.

@AgentS How can I disable the SSD in Windows so it doesn't have access to it? I would like to keep them completely separate

Normally, windows can't see Linux file systems, so you don't need to do anything. If you try and find some problem, post info.

1 Like

I had to reinstall Manjaro again and it seems that my Windows boot is gone again. I am guessing that it put it back on the SSD rather than the HDD where Windows resides. Is there a way to make it do that?

You have to check you're current status.
Check folder contents of $esp for window folders

efibootmgr -v
sudo inxi -Dpuoxxz
1 Like

As far as I can tell the Windows boot is on the SSD with Manajaro. I also noticed there are boot records from previous installs even though I chose erase entire disk when installing manjaro?

Is there a way to move the Windows boot record so it is on its own drive?

efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0000,0001,000B,0002,000A
Boot0000* Windows Boot Manager	HD(1,GPT,c0cdbef1-3b5a-4447-93ac-d46c931496b8,0x1000,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* Manjaro	HD(1,GPT,c0cdbef1-3b5a-4447-93ac-d46c931496b8,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000A* Fedora	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000B* UEFI OS	HD(1,GPT,c0cdbef1-3b5a-4447-93ac-d46c931496b8,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO

sudo inxi -Dpuoxxz
[sudo] password for workstation0: 
Drives:
  Local Storage: total: 1.03 TiB used: 6.84 GiB (0.7%) 
  ID-1: /dev/sda vendor: SanDisk model: SD8SNAT128G1002 size: 119.24 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> 
Partition:
  ID-1: / size: 99.72 GiB used: 6.82 GiB (6.8%) fs: ext4 dev: /dev/dm-0 
  uuid: 14703fd0-6c2e-4ff6-9b18-66e7b1d9fb26 
  ID-2: /boot/efi size: 299.4 MiB used: 25.0 MiB (8.4%) fs: vfat 
  dev: /dev/sda1 uuid: F3F4-5167 
  ID-3: swap-1 size: 17.12 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
  uuid: 89ba43bb-4aba-4d36-976e-61244ee73541 
Unmounted:
  ID-1: /dev/sda2 size: 101.83 GiB fs: crypto_luks label: N/A 
  uuid: 4251fca3-792f-4355-8664-dfbd03a0151f 
  ID-2: /dev/sda3 size: 17.12 GiB fs: crypto_luks label: N/A 
  uuid: 8081f5e6-2527-4f0e-b6df-74d67c85cedf 
  ID-3: /dev/sdb1 size: 16.0 MiB fs: N/A label: N/A uuid: N/A 
  ID-4: /dev/sdb2 size: 931.50 GiB fs: ntfs label: N/A 
  uuid: 56B8D59CB8D57B47

@shockwave

o Boot up manjaro and provide output from its terminal

ls /boot/efi/EFI/

If there is any output of Microsoft, then continue..

ls /boot/efi/EFI/Microsoft/

Tell us the output. If no output tell us too.

1 Like

Here is the output:

ls /boot/efi/EFI/Microsoft/
Boot Recovery

The trouble is... you keep installing manjaro and you keep wiping out windows boot.
In installing (and reinstalling) manjaro you should not format the $esp (didn't you read the install wiki before installing?).

Note that when you install Microsoft boot (per the link you provide), Windows will always wipe out other OS bootloaders.

/
\

Now do this.
Reinstall windows boot again. Your link is fine, but remember to do windows command as "admin".
After that, as said, you will lose your manjaro boot.
To get back your manjaro boot (and windows), see this (didn't you search first before asking?)

####################################################

  1. boot up livecd in uefi mode.
  2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg
  1. When booted
sudo grub-install 
sudo update-grub

##########################################################

Remember, do not format any existing $esp next time, like when you install again or another linux OS.

2 Likes

I don't know what/how Windows installs esp. The only way I can think of is remove/disable SSD when installing Windows. Remove physically the disk drive, or disable the drive from UEFI/BIOS , if there is an option for.
Manjaro should find windows installation when you run update-grub. You can even try that now.

1 Like

There is no windows efi file, in /efi/EFI/Microsoft which shares the same @esp as manjaro as shown in efibootmgr. update-grub won't cut it(won't work). OP has to reinstall windows boot.

2 Likes

The question is, how was that deleted, when AFAIK linux installers don't normally do that.

Didn't you read the OP solved this issue in post #5 @AgentS. The OP received advice from the best troubleshooters on the Manjaro forum and yet the OP managed to achieve the coveted self-solve. Obviously this user needs no more assistance as the self-solve indicates this user is proficient enough to solve their own self inflicted problems.

1 Like

I'm sorry, I missed it. But that doesn't match the topic info flow..?
Maybe someone accidentally clicked the solved button..

When we select the $esp partition as mount point /boot/efi and then click the box to format the partition.

Of course I only do 'manual' installation and I have several $esp's.
I don't know about the case where it is 'automatic' installation or 'let the installer install' or 'use free space' or 'install besides other OS' or whatever they're called.

1 Like

For all who might be wondering what Windows do when one presses Install button:

  1. It checks if there is a ESP partition on the disk. If it's available, it simply uses that. If not, it searches on another internal disks, and if it finds one, it uses it. If no ESP is available, it creates one.
  2. On ESP, it creates 2 folders with its files: Boot, where a fallback bootloader is installed, and Microsoft, with all crap it needs to be able to operate in normal way. That "crap" includes a bootloader (EFI/Microsoft/Boot/bootmgfw.efi), which is copied to EFI/Boot folder as a fallback option I've described above.
  3. It also creates some auxiliary partitions like Recovery and MSR, if they are not present already. Sometimes Recovery is not created.

It doesn't touch another partitions. The only thing that needs attention here is /EFI/Boot/bootx64.efi -- fallback loader. Every OS overwrites it during installation. Windows puts its own there (bootmgfw), Linux does the same (grubx64), but the problem is that the name for a fallback loader should be bootx64, so it always gets overwritten. This is why it's better to have separate ESPs for Linux and Windows. It's not crucial, but it lets keep 2 different worlds separate and prevent possible issues. However, one should keep in mind that deletion of Windows ESP and consequent re-installation will result in Windows re-using another available ESP so it's better not to touch it at all.

My apologies, everybody. I just made a similar mistake in another topic which reminds me to come back here to make amends.
The file is in /boot/efi/EFI/Microsoft/Boot/ not /boot/efi/EFI/Microsoft/
There should be indeed a microsoft efi file and it is in
/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

Cheers.

Thanks, everyone for all of your help. I can see now how this happened. As mentioned, It would have been best to disable one of the drives so I could force Windows to not use a previous boot, but at this point I have both systems working well. I did have to fix the Windows boot each time I installed Windows, but it it a pretty simple fix.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by