Windows dual boot, new install, Failed to start Load Kernel Modules.

Hello All

New here, long time Linux user (though it was Ubuntu for a long time, so I hear that may not count). Writing currently on an old Core2 Duo laptop that is successfully operating Manjaro Architect (Gnome Desktop). Not being one to dig into the weeds too often, I'll start with a bit of history, then try to provide as much detail as I can about the current issue..

Recently found a need to operate Linux on a more powerful machine so made the decision to try to dual-boot my Windows Desktop. Having had difficulty setting up dual boot in the past (this laptop theoretically has a Windows partition that I'm pretty sure is hosed - not a big deal on this machine) I used a set of instructions found on this forum to try to setup a dual boot on my Windows gaming PC ([HowTo] Dual-boot Manjaro - Windows 10 - Step by Step)

Unfortunately, it seems the Architect installer doesn't offer the same 'manual partition' menu, thankfully I've some experience with fdisk, and parted, so I am reasonably sure I have the partitions setup correctly. Using Windows I sliced off 100G of a data drive to attempt the dual boot. fdisk -l below (The NVME drive is all Windows, Manjaro installed on sda (EFI on sda2, swap on sda3, root on sda4, home on sda5)

Disk /dev/nvme0n1: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: WDC WDS512G1X0C-00ENX0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 0E01F514-5AE2-43C8-948F-0DF83132853C

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 923647 921600 450M Windows recovery environment
/dev/nvme0n1p2 923648 1126399 202752 99M EFI System
/dev/nvme0n1p3 1126400 1159167 32768 16M Microsoft reserved
/dev/nvme0n1p4 1159168 998456018 997296851 475.6G Microsoft basic data
/dev/nvme0n1p5 998457344 1000212479 1755136 875M Windows recovery environment

Disk /dev/sda: 1.37 TiB, 1500301910016 bytes, 2930277168 sectors
Disk model: WDC WD15EADS-00P
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 8A33DFD4-6013-4187-9AF4-B23D3AF1AE97

Device Start End Sectors Size Type
/dev/sda1 2048 2720561151 2720559104 1.3T Microsoft basic data
/dev/sda2 2720561152 2721609727 1048576 512M EFI System
/dev/sda3 2721609728 2738386943 16777216 8G Linux swap
/dev/sda4 2738386944 2872604671 134217728 64G Linux filesystem
/dev/sda5 2872604672 2930277134 57672463 27.5G Linux filesystem

History continued:

It did take a few tries to get to what appeared to be a functioning state..
Attempt 1: Although partitioning and mounting steps were run through multiple times, when an attempt was made to install the Manjaro Desktop an error indicated that partitions had to be mounted first.
Attempt 2: partition/mount worked on first attempt. Tried to use the installer menu to load proprietary drivers for the nVidia graphics card - screen went dead. After reading several other threads here I decided it was more worthwhile to get the system up and running before monkeying with graphics drivers.
Attempt 3: Installation completed successfully, however the X11 system somehow became configured to use a 'ue' keyboard layout rather than 'us'. After using TTY2 to update /etc/X11/xorg.conf.d/00-keyboard.conf appropriately, rebooted in an attempt to reload X11 and came to the current situation.

The current situation:
One of the first messages seen during bootup is "[FAILED] Failed to start Load Kernel Modules."
Another messages during boot sequence is a failure to load the EFI partition:
[FAILED] Failed to mount /boot/efi.
See 'systemctl status boot-efi.mount' for details.
[DEPEND] Dependency failed for Local File Systems.

After a bit of digging I found that the system doesn't seem to like the 'vfat' filesystem defined in fstab... I'm guessing this has to do with the previous failure to load kernel modules.

The system allows me to login to emergency mode. Running 'systemctl status systemd-modules-load.service' (also 'journalctl -u systemd-modules-load.service') reveals two errors on each boot:
Failed to lookup module alias 'crypto_user': Function not implemented
Failed to lookup module alias 'uinput': Function not implemented

I've looked at a few threads here regarding the two errors above and wasn't able to pick out a pattern in terms of the next troubleshooting steps. Here is output from a few commands I saw elsewhere:

inxi -Fxxxz
System:
Host: Genji Kernel: 4.19.85-1-MANJARO x86_64 bits: 64 compiler: gcc v 9.2.0 Console: tty 1 dm N/A Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: MSI model: B250M MORTAR ARCTIC (MS-7A69) v: 2.0 serial: UEFI: American Megatrends v: A.10 date: 02/07/2017
CPU:
Topology: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L1 cache: 256 KiB L2 cache: 8192 KiB L3 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 67224
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 802 5: 800 6: 800 7: 800 8: 800
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTek driver: N/A bus ID: 01:00.0 chip ID: 10de:1c03
Display: server: X.org 1.20.5 driver: N/A tty: 192x60
Message: Advanced graphics data unavailable in console for root.
Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI driver: N/A bus ID: 00:1f.3 chip ID: 8086:a2f0
Device-2: NVIDIA GP106 Definition Audio vendor: ASUSTeK driver: N/A bus ID: 01:00.1 cip ID: 10de:10f1
Network:
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: N/A port: f000 bus ID: 00:1f.6 cip ID: 8086:15b8
Device-2: Realtek RTL8812AE 802.11ac PCIe Wireless Network Adapter vendor: D-Link System driver: N/A port: d000 bus ID: 03:00.0 cip ID: 10ec:8812
Drives:
Local Storage: total: 1.83 TiB used: 6.41 GiB (0.8%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS512G1X0C-00ENX0 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: rev: B35500WD scheme: GPT
ID-2: /dev/sda vendor: Western Digital model: WD15EADS-00P8B0 size: 1.36 TiB speed: 3.0 Gb/s serial: rev: 0A01 scheme: GPT
Partition:
ID-1: / size: 62.50 GiB used: 6.36 GiB (10.2%) fs: ext4 dev: /dev/sda4
ID-2: /home size: 26.94 GiB used: 44.5 MiB (0.2%) fs: ext4 dev: /dev/sda5
ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
Message: No sensors data was found. Is sensors configured?
Info:
Processes: 134 Uptime: 49m Memory: 15.63 GiB used: 132.8 MiB (0.8%) Init: systemd v: 242 Compilers: gcc: N/A Shell: bash v: 5journalctl -u systemd-modules-load.service.0.11 running in: tty 1 inxi: 3.0.36

Though I've lost the thread (and don't think it's related anyway) I have confirmed that the UUIDs defined in fstab match UUIDs reported by the drives.

Somewhere I read that someone had a similar issue and was able to get the system to load by 're-installing the kernel'; this and other solutions involving use of 'pacman' fail for me as the Network adapter doesn't seem to have any drivers loaded so the system can't pull any resources from the outside world.

Any assistance or referrals to threads I may have missed are welcome!

Thanks.

Update for those who may be looking for a solution to this type of issue.

After several re-installation attempts using the Manjaro Architect media, I kept landing in the same set of errors on boot. Every attempt to boot from /dev/SDA failed.

Today I ran through the Manjaro Gnome GUI installer and found that I am able to consistently boot from the internal drive.

I suspect that the difference is either somehow in the code behind the GUI installer vs. that of the more texty Architect build installer, or perhaps in the way flags are set on the EFI partition using varying tools available.

In either case, I now have a working dual boot with Windows 10 & Manjaro - Yay!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by