Windows partition is mounted read-only for (apparently) no reason

Short story:

my Windows NTFS partition is always mounted read-only by default.

Long story:

I have always had Windows 10 and a bunch of Linuxes installed, but I have never used Windows for a long time until a few months ago. I was using Linux Mint 18.3 KDE as my main OS at that time.

Using Windows made it apply the updates (even if I had disabled automatic updates, I don't know how this is possible). Fast boot has always been disabled, but I think that when updates are pending or left unfinished Windows leaves the partition in a “hybernated” state anyway.

So I made Windows finish all its updates, but Linux Mint kept on saying that the Windows partition could be mounted only as read-only.

Surprisingly, the problem disappeared when I had to use Boot-Repair to fix some problems with GRUB (I don't remember exactly, probably I had messed things up by installing another Linux distro).

But then the problem came back, maybe because I had used Windows again.

Now I have made a new Manjaro install. I made Windows do all its updates before installing, but Manjaro has always mounted Windows partition automatically as read-only. And Linux Mint KDE still refuses to mount Windows partition as read/write.

I have double-checked:

  • there is no Windows update pending
  • fast-boot is disabled
  • ntfs-3g is installed
  • there is no fstab entry for the Windows partition, so I think Manjaro is autonomously deciding to automount it as read-only

I could try using Boot-Repair again but I wouldn't like to loose the graceful Manjaro's GRUB menu.

Can anybody help me find out why this is happening?

One solution would be to add an entry instead of letting it automount.

What is the output of the command:

mount | grep -i ntfs
1 Like

If you are having problems reading and writing to your NTFS drives then Windows may be causing this.

In Windows:

Disable hybrid sleep
Disable fast startup
Disable hibernation completely: in an elevated command prompt, (from within Windows) run:

powercfg /h off

Even if you have disabled these features in Windows in the past you should recheck their status.

Windows update may have re-enabled these without your knowledge.

You may need to mount your NTFS drives via fstab using the correct NTFS permissions options.

This issue may be fixed by using the nftsfix command from a terminal.

Locate the device and the partition with this command:

lsblk

Unmount the partition

sudo umount /dev/sdxY

Use the nftsfix command on your problematic NTFS partition.

sudo ntfsfix /dev/sdXy

You must subsitute yiur drives designation for "Xy" in the above commands.

If this still does not resolve your issue then run a scandisk on the NTFS partition from within Windows.

8 Likes

There is no output.

I can't find any hybrid sleep option anywhere. If I look for ”disable hybrid sleep” on Google I find the same instructions that apply to disabling fast boot.
Are both “hybrid sleep” and “fast startup” just the fast boot option, or am I missing something?

Sorry Windows has changed a lot since I've used it last. I'm really not up on my current Windows info.

2 Likes

I think this is the deal now but the name doesnt matter too much (disabling hibernate or hybrid-sleep should achieve it anyways) .. its more of a marketing tactic..
M$ wants people to think they have a 'start up super fast' option ... when really it is a 'never turn off all the way so it appears like i boot fast' option.

1 Like

I have tried this and now it works.

I have found a video tutorial on how to do that, but the option was not there (maybe because I had run that CLI command before looking for that).

I also noticed that there were those white rotating dots while booting Windows, maybe there still was some update to be completed.

Anyway, problem solved (for now). Thanks!

1 Like

You need give permissions from Windows 10 to this partition read it post

Glad that solved the issue for you.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by