Windows Update broke dual boot | "Invalid Filesystem"

When I boot I see a grub rescue prompt… "Invalid filesystem" or something like that. I am on a live usb right now, and the file system where manjaro was installed to is still there.
I followed this Guide when installing manjaro.

After completing the "How to rescue grub guide" I still get the unrecognized filesystem rescue menu.

I can boot into my system with the recovery stick, then looking for loaders and selecting (hd1,gpt6)/efi/Manjaro/grubx64.efi.

Any help on how to get grub running again is appreciated :slight_smile:

When you root, you don´t need to use sudo.
Just use "manjaro-chroot -a".

1 Like

I forgot my bad, anyways I'm doing the manual path now. (Your suggestion didn't make a difference anyways)

sudo manjaro-chroot -a

type 1 if only one line appears not 0 ...

Interesting, it should then not display 0) Manjaro in my opinion :slight_smile:

You try to set the right boot option via UEFI Bios.

I fixed it by deleting (otherwise I was just getting the unknown filesystem grub rescue menu) the partition responsible for boot/efi, doing the manjaro grub restauration guide, then changing the uuid in etc/fstab to the new uuid of the efi partition and updating grub again once manjaro booted (Otherwise grub just booted directly into manjaro/ there was a black screen instead of the system selection).

List form:

  1. delete partition responsible for boot/efi
  2. manjaro grub restoration guide
  3. Update fstab to include the correct uuid
  4. Step 5 from the restoration guide (sudo update-grub) executed again on manjaro
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by