Wireless (Intel Dual Band 3165-AC) disconnects after updating all packages from clean install

Hello everyone,
I have switched to Manjaro xfce from Windows 10 but am having problems with the wlan. While on the live-usb as well as after the installation of Manjaro my wlan works fine. As soon as I update all the packages and restart my PC the wlan disconnects after 1-2 minutes. Before trying Manjaro, I tried Ubuntu 18.04.2 where I had the same problem. I've tried not updating the networkmanager packages, but I still have the same problem. I tried turning of randomize MAC address.

Does anyone know a package that might be breaking something? Or any known problems with my wlan component? I would be really grateful for any help, I was really looking forward to Manjaro :frowning:
Output if inxi -Fx

System:
  Host: tobias-pc Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 80QD v: Lenovo YOGA 700-14ISK 
  serial: <root required> 
  Mobo: LENOVO model: VIUU4 v: SDK0J40709WIN serial: <root required> 
  UEFI: LENOVO v: DBCN22WW date: 09/07/2015 
Battery:
  ID-1: BAT0 charge: 33.8 Wh condition: 33.8/45.0 Wh (75%) 
  model: SMP L14M4P72 status: Full 
CPU:
  Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20744 
  Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce 940M] vendor: Lenovo driver: nouveau 
  v: kernel bus ID: 02:00.0 
  Display: x11 server: X.Org 1.20.4 driver: intel,nouveau 
  unloaded: modesetting resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.3.4 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: efa0 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: e0:94:67:8f:e2:d8 
Drives:
  Local Storage: total: 238.47 GiB used: 6.30 GiB (2.6%) 
  ID-1: /dev/sda vendor: LITE-ON model: CV1-DB256 size: 238.47 GiB 
Partition:
  ID-1: / size: 233.43 GiB used: 6.30 GiB (2.7%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 176 Uptime: 9m Memory: 7.69 GiB used: 1.27 GiB (16.5%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.32 

output of rfkill list all

0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

First thing to do disable IPv6 in Network Manager or your router, (or both).

1 Like

Disable IPv6 and then try updating all packages?

Being fully updated would be best.

I would also install and test at least 3 different kernels. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

Is your bios at the most up to date version?

1 Like

Disable Network Manager's WiFi power saving features with the following command:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

This change can be reversed by deleting the newly created file with the following command:

sudo rm /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot after creating (or removing) the Network Manager configuration file.

I've tried with the 5. Kernels, they didn't help. I haven't tried 4.14
Atm I can't open NetworkManager and I can't install new kernels until I update my packages ?

I'm not sure, I'll try and find out if BIOS is up to date.

I tried the power saving feature on Ubuntu, I'll try that here as well.

Please post:

sudo dmesg  | grep -Ei 'error|segf|fail|broke|warn|dump|denied|firm|regdom|wmi|rtl|wl|ath|b43|bcm|brcm|eth|enp|r816|blue|deauth' | grep -viE 'acpi|ras'

Have you tried USB phone tethering to get a connection.

Have you tried disabling bluetooth temporarily.

sudo systemctl mask bluetooth

Reboot

Simply repeat the command using "unmask" to enable it again.

[    0.251680] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.533729] platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0xfed40fff]
[    0.600801] pci 0000:02:00.0: BAR 6: failed to assign [mem size 0x00080000 pref]
[    2.428734] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[    2.438316] iwlwifi 0000:01:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
[    2.580894] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
[    2.598826] iwlwifi 0000:01:00.0: base HW address: e0:94:67:8f:e2:d8
[    2.684785] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    2.685126] thermal thermal_zone3: failed to read out thermal zone (-61)
[    2.692414] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
[    2.898963] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x595f03)
[    2.931076] Bluetooth: Core ver 2.22
[    2.931110] Bluetooth: HCI device and connection manager initialized
[    2.931114] Bluetooth: HCI socket layer initialized
[    2.931116] Bluetooth: L2CAP socket layer initialized
[    2.931123] Bluetooth: SCO socket layer initialized
[    3.037202] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[    3.070298] Bluetooth: hci0: read Intel version: 370810011003110e00
[    3.071749] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8.10-fw-1.10.3.11.e.bseq
[    3.106125] [drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)
[    3.108106] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.108110] Bluetooth: BNEP filters: protocol multicast
[    3.108120] Bluetooth: BNEP socket layer initialized
[    3.139011] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[    3.174190] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.RP09.PEGP handle
[    3.250564] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[    3.288301] Bluetooth: hci0: Intel firmware patch completed and activated
[    3.324354] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[    6.102653] audit: type=1131 audit(1562410895.850:38): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@0-676-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   10.822836] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[   12.011975] Bluetooth: RFCOMM TTY layer initialized
[   12.011982] Bluetooth: RFCOMM socket layer initialized
[   12.011997] Bluetooth: RFCOMM ver 1.11
[   12.321127] wlp1s0: authenticate with 64:a2:f9:f1:eb:43
[   12.322606] wlp1s0: send auth to 64:a2:f9:f1:eb:43 (try 1/3)
[   12.368157] wlp1s0: authenticated
[   12.368619] wlp1s0: associate with 64:a2:f9:f1:eb:43 (try 1/3)
[   12.383043] wlp1s0: RX AssocResp from 64:a2:f9:f1:eb:43 (capab=0x1431 status=0 aid=6)
[   12.384138] wlp1s0: associated
[   12.485453] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready

I haven't tried USB phone tethering - I'll try that as soon as I've updated the packages and replicated the problem. I've tried disabling Bluetooth

Please let me know all the things you have tried that have NOT worked as that is not only helpful, but saves wasted time.

Yes of course - sorry. It's been quite a jumble and I'm not sure I remember everything..
Randomized Mac address
Set country code
Installed kernel 5.0.21_rt14-1
Updated all packages except: network-manager-applet, networkmanager, NetworkManager
Updated all packages except: network-manager-applet, networkmanager, NetworkManager, nss, ntp, libnma, libnm, libnm-glib, iproute2
Installed Ubuntu 18.04.2 (tried turning power saving off)
Installed Manjaro with drivers=non-free
Turned off Bluetooth

As soon as packages are updated and I reboot and I lose the wlan connection, I'll try:
disable IPv6, try USB tethering, check if the output of dmseg | grep ... changes, try 4.14.130-1, 4.19.56-1 and 5.1.15-1 kernels

Very helpful, thank you.

I would test the 5.1 and 5.2 kernels.

You haven't tried installing the firmware directly from Intel?

I will. Thanks a lot already for your help!! I'll give an update as soon as I've done everything..

This is the output after updates (not sure if this is relevant):
Warning: dependency cycle detected:
Warning: bashrc-manjaro will be installed before its bash dependency
Warning: dependency cycle detected:
Warning: harfbuzz will be installed before its freetype2 dependency
Warning: dependency cycle detected:
Warning: libglvnd will be installed before its mesa dependency
Warning: dependency cycle detected:
Warning: x264 will be installed before its ffmpeg dependency
Warning: dependency cycle detected:
Warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
Warning: dependency cycle detected:
Warning: lib32-libglvnd will be installed before its lib32-mesa dependency
Warning: audit: directory permissions differ on /var/log/audit/filesystem: 755 package: 700

Oh cr@p, I hate dependency cycle warnings. I suggest you do some searching I don't know what the best advice on that issue is.

Well if the power saving changes to NM didn't help there's one more thing regarding power saving to try.

sudo systemctl mask tlp

Reboot

Also, do you have multiple AP's in the vicinity. If so, locking your BSSID in NM might be a good idea.

If there is more than one AP in your vicinity (or you have a dual-band AP with a single SSID) this can result in dropped connections.

Your connection can be lost because of constant scanning by Network Manager, and confusion over which AP to connect with.

To eliminate this possibility you can lock your WiFi connection profile to the BSSID of your favored access point in Network Manager.

You can do this in Network Manager's "Wi-Fi" tab in your connection's properties settings.

There is a "BSSID" drop down field where you can select and lock your Wi-Fi to a single BSSID.

Both power saving methods don't work.
Turning off Bluetooth doesn't work.
Kernel 5.2 and 5.1 don't help.
USB tethering work fine!
I have yet to try disabling IPv6, locking in BSSID and installing firmware from Intel.
Will update later today :slight_smile:

1 Like

You also want to make sure you don't have any hostname or IP address conflicts. One of your error messages made me wonder about that.

Alright: so disabling IPv6 didn't work (i changed ipv6.disable=1 in the /etc/defaults/grub file).
Locking BSSID doesn't work.
I'm not sure how to check hostname/IP address conflict.. I am doing this on my mobile hotspot, but I have the same problem with other networks...
For the moment working with USB tethering is ok-ish, as I nearly always use my mobile hotspot anyways..
I found this bug report which looks like the same problem: https://bugzilla.kernel.org/show_bug.cgi?id=198645
--> with sudo dmseg | grep iwl i get the same error as in the bug report:

iwlwifi 0000:01:00.0: Failed to wake NIC for hcmd [ 3641.034032] iwlwifi 0000:01:00.0: Error sending STATISTICS_CMD: enqueue_hcmd failed: -5

Going to try installing firmware from Intel tomorrow (i'm not quite sure on how to do it - I have to find a good instruction set)..

These links have similar or maybe even same issues:
https://archived.forum.manjaro.org/t/wireless-randomly-dies-recoverable-only-by-rebooting/65326/25
https://archived.forum.manjaro.org/t/4-19-x-breaks-iwlwifi-for-me/68592
I'll go through them and check for solutions as well :slight_smile:

Forum kindly sponsored by