WLAN password not acceted

Hi all

I am quite new to Manjaro, so please be gentle if I placed my post into the wrong category.

I am trying to connect to my WLAN but the password does not get accepted. I am really extra sure I did not make any typo because I copied the password from my keepass store like I did for a lubuntu new installation where it worked perfectly well. I use the NetworkManager applet in version 1.8.24 vanilla of my LXQt 19.0.2 install.

My router just tells me that the WLAN key/password was invalid.

I wonder whether the applet has problems with certain special characters or password of 32 chracters length.

Does somebody have an idea?

Kind regards

Thiemo

Click the option of show password - then compare.

Identical

No clue - Network Manager is the latest version and I know of no bugs with relation to authentication.

Let me boot my test system using lxqt and check.

Does it connect to wifi when using a live USB?

Hm, I actually did not try. I had it cabled. I was being lazy postponing that I had easy access to the complicated password. I shall try.

I have a test AP - not very complicated - it connects fine.

I will check with a complicated password - what is the criteria used?

32 characters: both "size" letters numbers and %)#=/%~"$:;?

Second test - you cant paste the password in the dialog - at least I couldn't had to type it - but no problems with 32 chars using spaces and everything.

Uh, there actually is a backslash not being visible anymore after I removed the t in the special characters

backslash is no problem with my test AP

Tested with password

5\!0TeYbu-hTk8sTo7CQ!f( 59:pU4Bs

I recorded a 2.7 mega screen capture where I paste the password. However, for some reason this time the authentication dialog did not reappear...

I believe you - I just couldn't paste it - the main thing is - a complicated password works on the live ISO. I have no physical install and for the record - it doesn't matter as the ISO is the install - if you use the graphical installer (Calamares).

Your speials

\!-!( :

Mine

%)#=\/%~"$:;?

I wonder whether one of the others are causing problems.

%)#=/%~"$;?

I bet they don't

I use a password generator

https://passwordsgenerator.net/?length=32&symbols=1&numbers=1&lowercase=1&uppercase=1&similar=0&ambiguous=0&client=1&autoselect=1

I am going to doublecheck with the live ISO.

It must be something in your process - I don't know what.

Just checked with the fourth password of a special kind

5(!0TeYbu-hTk8sTo7CQ!f( 59:pU4Bs
5\!0TeYbu-hTk8sTo7CQ!f( 59:pU4Bs
TK7N3@!^ccy`&D%8k*{IT=6;sAWEzVpt
E8(<Fz;eldHJ\0)<0%},As;FILi%#i2,

There is no issues for me - except that I have to type it in manually - cannot paste - at least not on the live ISO.

I can reproduce the behaviour with the 19.0.2 lxqt live ISO, i. e. both behaviours. I can paste there and the authentication dialogue reappearing.

That is weird - for a number of reasons

  1. I am maintaining the Openbox based Editions
  2. I cannot reproduce the behavior though I downloaded the ISO from OSDN
    • presumably the same you are using
    • manjaro-lxqt-19.0.2-minimal-200307-linux55.iso
  3. My test system is a cheap $200 Yepo laptop
  4. My test AP is a generic Netgear Nighthawk X6S device
  5. I have tested the above mentioned 32 char WPA authentication codes (four different codes) without any issues
  6. The only difference is that you paste the code somehow - I type it in by hand

I am convinced it must be something on your end - I just don't know what.

Have you tried typing in your authentication code by hand?

Please do try it - I think it is something with the paste which includes a non printable character.

My ISO has the name manjaro-architect-19.0-200223-linux54.iso so apparently I did not get my hands on the very last. Funnily, I downloaded it just yesterday...

All wrong I tried that before but switched to yours. Sorry for the confusion.

Forum kindly sponsored by