Won't boot beyond the login screen

I installed Manjaro and did the first boot. Then I updated the OS. Then I went to device manager and selected the option auto update/install proprietary firmware. After a while when it was installing firmware for my GPU Nvidia GTX 1050Ti (firmware was named nvidia-bumblebee) it ended with a error "Package manager instance still running" (i am not quite sure it was something similar). So I restarted the system. It came back to a new login screen (not the one i logged in during my first boot). When I enter the password and try to login it verifies the password then the deepin's login sound is played. Beyond that it doesn't load the desktop.

I force rebooted the machine and tried the Power Options in the login screen and it froze once I pressed reboot.

I am a complete noob on arch based distros. This is my first time using Manjaro. So please take care of me.

1 Like

As this is a fresh install I'd start over. Reinstall, make sure everything is working as expected. Update the system, reboot, make sure everything is working as expected. Then you can start messing about trying things out.

As you're new to this stuff expect to break the system a few times before you get used to how it all works. :slight_smile:


If using amd graphic cards, recommend you do not use proprietary drivers.

1 Like

OP is using a GTX 1050Ti

Thanks @jonathon. I can easily reinstall and your correct about learning by making mistakes. :stuck_out_tongue_winking_eye: But I would like to is there any possible fix for something like this. I mean like restore to a previous point or fix the os using a live cd.

In which case, search the forum for how to switch graphics card drivers using the CLI.

Keep in mind that it's easier to start over until you have enough experience to know what you did "wrong"; if you don't, finding the cause and fixing it is pretty much impossible.

1 Like

@jonathon As you recommended I did a clean install of the OS using the latest stable deepin release 17.1.7 from this announcement.
But the problem still exists. When I posted the topic I installed 17.1.2 and after I updated it was updated to 17.1.6.
So the problem exist in 17.1.7 as well.

The attached image shows the warnings i get while booting up the system.

When you booted into the installer, did you choose the free or non-free drivers?

Will your system boot with the non-free drivers selected?

If not, have a read of these threads:

I tried all the above solutions but wasn't successful so far. The computer won't boot with non-free drivers. The steps was displayed as "Starting BumbleBee C ..."(something i can't remember). Followed by Reached Graphical User interface and it freezes there.

I thought this might be something to do with the Deepin desktop environment, so I tried switching to KDE. But yet still its still the same.

1 Like

OK. I've found the fix. For a clean install proceed from step 1. Or if you have already installed the os proceed from step 7.

  1. Create your live usb and boot from it.

  2. Once you reach grub select non-free drivers.

  3. Then move the selection to Boot: xxxx and press E

  4. Insert flag systemd.mask=mhwd-live.service

  5. Once in live session, before installing you have to edit with sudo the following file:
    sudo nano /usr/lib/calamares/modules/mhwdcfg/main.py
    and make the following change

def run():
    """ Configure the hardware """
    mhwd = MhwdController()
    # return mhwd.run()
    return None # <- Add this and comment the above line

Press Ctrl+o to save and press enter. Exit the terminal.

  1. Run the installer and you will be able to successfully install the os. and Reboot.

  2. When you reach grub select your OS and press E.

  3. Insert kernel flags acpi_osi=! acpi_osi="Windows 2009"
    How to insert kernal flag
    Read this answer and also make these flags permanent as well. When doing so insert a replace "Windows 2009" with \"Windows 2009\"

  4. First of all update your system with sudo pacman -Syu and once completed install the linux headers with sudo pacman -S linux414-headers (replace 414 with your version) then the non-free drivers with sudo mhwd -a pci nonfree 0300 and follow the bumblebee instruction from manjaro website.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by