Won't boot - mount point? last system update? or what?

I'm new to this forum - a senior citizen tired of Microsoft.

I've got a OS - root drive mount point - corruption problem - maybe - I don't know for sure.

While working with files in Thunar (Manjaro) - I needed to drag a folder tab to the side-pane to create a shortcut for the folder - since Thunar does not have a "Bookmark" feature. (that I know of)

I was trying to put the tab shortcut between the documents and trash icons.

In the process of dragging the folder tab I accidently released the button while on the trash icon.

At first, I thought I didn't do it right because I didn't see the new shortcut I tried to make.

Then I opened the trash folder and sure enough - it was there, not the shortcut - the whole folder and contents.

I tried to "restore" the folder back to normal but it wouldn't. So, I went to the trash folder as root in thunar and copied all the files back to the orginal folder on the hard drive.

But the process corrupted the root partition's mount point because the device name for it was all numbers - no name.

I used gnome disk utility to look at it - and it did not look right. I must have corrupted the mount point even more - because now after trying to reboot later, the boot process goes fine to the password screen.

When I enter the password and press enter - it continues as normal for a couple of seconds and returns to the password screen. It does not give a wrong password message - just the screen again - over and over.

I booted from the Manjaro live USB so I could go back into gnome disk utility and "Repair" the mount options. But my 4GB live USB didn't have enough space to install the gnome disk utility on it.

So far, I've not been able to use the disk utility at all or fix the problem.

I download the latest copy of manjaro in an effort to make a new live USB with a larger capacity jump drive but I couldn't find the appropiate program to make the usb bootable for Manjaro.

but by this time I was to tired and mentally exhausted from the process of trying to fix it - so I took a nap.

NOW! What do I do??

  1. Try to continue fixing the problem for the experience?

Or

  1. Re-install Manjaro fresh from the ground up and forget about correcting the corrupted mount point?

I have no idea if it is a mount point problem or last system update glitch or what.

Thanks for your help

Rod

Hi Rod (as another one of those senior "aged" manjaro types) I'd say it sounds like you really borked it. :slight_smile:
If it were me... I'd re-install.

Going forward there is tons of help for all things open source. Here's a sample of items on Thunar bookmarks; https://goo.gl/pkbcSt

This is a valid clue that says you system is fine.
My advice:

  • Boot to Login screen
  • Go to TTY (Press Ctrl+Alt+F2) and login with your user credentials
    • If it is not successful, try to login as root
  • Create a new user
    # useradd -m newusername
  • Logout the user session
  • Login with your new user's credentials,
    • in TTY and then run startx
      or
    • going to Login Manager with Ctrl+Alt+F7

Thank you manyroads for guiding me to the Thunar bookmak articles - that I didn't find.

1 Like

Thank you petsam for your advice I just tried it and something is not working.
I also get these "Failed" lines during the boot process before the login screen.

Failed to start load kernel modules
a few lines later
Failed to initalize hardware monitors
a few lines later
Failed to start light display manager
then it stopped completly with a flashing cursor after the next line
Reached target printer

I was still able to go to TTY with Ctrl+Alt+F2
When logged in with origjinal credentials I get this

-- u3x: /home/u3x: change directory failed: no such file or directory
logging in with home = "/",
[u3x@u3x-pc /]$

Then, when I add a new user name
sudo useradd -m ultrapc and enter - I get the following
[sudo] password for u3x (u3x) is the original corrupt user I'm trying to fix
so I enter the orig password as it asked and get this
[u3x@u3x-pc /]$

It did NOT ask me for a new password or was it not supposed to?
I logged out as you advised - and back in. I entered the new username with the old password - cause it did not ask me for a new password.
and I get this -

login incorrect
u3x-pc login: and it keeps repeating itself every time I enter old or new username.
What am I doing wrong?

Thanks for helping

I don't know how those words were made bold - I didn't intentionally do it.

It is because of some of the characters - please enclose your outputs in code brackets:

[code]
####like this####
[/code]

You probably have problem with your home folder.
Root home is in /.

Thanks for staying with me.

I was able to create a new user (ultra3x and add a password.)
when I login to ultra3x from TTY - I get this

Last login: Mon Apr 30 12:50:30 on tty3
[ultra3x@u3x-pc ~]$ (so I try to log in as root)

[ultra3x@u3x-pc ~]$ su
Password: (I entered new password and get the following) several times.

su: Authentication Failure
[ultra3x@u3x-pc ~]$

Now do I enter (startx) here or is there something else I need to do first?

Also, when I list (ls) the new ultra3x user I get this -

[ultra3x@u3x-pc ~]$ ls
Desktop Documents Downloads Music Pictures Public Templates Videos

Thank you

This points to wrong password for root user. You should know the root password and if it is different from first user created.
The rest about your new user behavior looks normal. At that point you run startx

1 Like

I'm tired and didn't notice that the su password was my original password as well.
It worked as you can see in the attached picture, which also shows the error result of the - startx - command.

I hope working this problem out - helps someone else as well.
Thank you for your help.Startx%20-%205-1-18

1 Like

I thought I was clear about by suggestions. Sorry. I suggested to run startx after logging into the new user account, not from root login.
Anyway, it seems possible you have video driver problems and not mount, which I can't connect to your findings.

Also tell us what folder did you move/trash, what name/path?
While in TTY,

  • login as a normal user (old or new) and try startx. It might fail.
  • If it fails
    • Check your video driver installed
      mhwd -li
      and you might need to re-install it
  • Give more info about your system
pwd (this will show your current path)
inxi -SMGxxz
lsblk
ls /home
cat /etc/X11/xorg.conf.d/*.conf
cat /var/log/Xorg.0.log | grep EE

If you can't copy the text outputs here, then add to the end of above commands

 > pwd.log
 > inxi.log
etc..

and get them at the path showed from 1st command, after booting a LiveISO.
Post them here using code blocks, please.

The folder that was accidently trashed was "DataDrive DS 3"
which was the main folder of a separate hard drive from the OS drive, it contained all the folders and files of that drive. I moved all the folders and files from the following trash folder - so it is now empty.
/run/media/manjaro/Hitachi DS 3/.Trash-1000/files/DataDrive DS 3/

In the last part of your last post you stated:
"and get them at the path showed from "1st command", after booting a LiveISO."
This instruction is too general, 1st command in which post? or which section? I'm tired and don't get quality sleep even when I am asleep - I can't follow exactly what you mean.
If you want me to use code blocks, you'll have to show me how to use them.

My Manjaro liveISO works fine with the same machine - as it should.

Here are the latest proceedings.
mhwd%20-li%20%20%20%20%205-1-18

Thank You

Select the code text (terminal output) and click the button
Screenshot-121-1134

The commands in that specific post.
Example:

cat /etc/X11/xorg.conf.d/*.conf > xorg.conf.log

This will create a file xorg.conf.log at the active dir (which is the output of pwd command), ie /home/ultra3x

Since you can run the live ISO well, you can boot it and mount your manjaro installation , probably /dev/sdc3 , and on this, go to /home/ultra3x and you will find the log file created, open it and copy/paste the contents to your next forum post.

Notice: you did a typo error on the command
cat /etc/X11/xorg.conf.d/*.conf X11 is with capital X.

It seems you have created several users. Are they all test users during this troubleshooting? There is no u3x user folder.
Please check each one (if you are not sure) to see if one of them is your initial/main user folder (if it contains dot files) ls -a /home/username. Have you accidentaly renamed your user folder?

In TTY you can login as a normal user (not root) and then run startx.

If you cannot have GUI (your DE or Display manager) then check if you have a Xorg conf file in /etc/X11/xorg.conf.d/ and delete it (except `keyboard.conf if it exists).
Then reboot.

I appreciate everyone helping with this problem I could have created trying to save my data from the corrupted user account. Please bear with me if I'm not able to follow directions correctly.

I'm using pictures because the corrupted user is on my desktop - which I can only access from the tty or the manjaro live usb.

If you have a better process to see what my desktop is doing - explain it please.

Here is the text from the xorg.conf.log file -

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
	MatchIsKeyboard "on"
	Option "XkbLayout" "us"
	Option "XkbModel" "pc105"
EndSection

All the user accounts you see - were created during this troubleshooting.
Since the u3x2 doesn't have any folders - could it be the corrupted user?

This picture shows their contents.
ls%20home%20username%20info
The only file in /etc/X11/xorg.conf.d is the 00-keyboard.conf

No change in boot process. Same FAILED to load - lines during boot up.

No difference in the startx error message.

Thank you

What would you mean?

Please do these:

  • Boot your PC up to TTY
  • Login as root (username) with root password.
passwd ultrapc
  • Give a new password for user ultrapc
  • exit
  • Login with user ultrapc
  • startx

Post any errors.

I was able to log in as root and give ultrapc a password as you instructed.
But the startx command still did not work as seen in picture below.

Thank you for helping.
startx%20result%205-3-18

Is this problem fixable??

Thank you

Now you have a "decent" problem! Maybe a GPU driver or configuration.
While you are in TTY and logged in as your user (ultrapc) try this:

  • Upgrade your system
sudo pacman -Syyu
  • Uninstall your graphics drivers and use free (embeded in system/Xorg)
mhwd -li

this will show the installed driver. Then..

sudo mhwd -r pci {your-listed-driver-name}
reboot

You should be booted at you login screen now. Login as your user and post here the output of thiese commands (use code blocks in your post):

cat /etc/X11/xorg.conf.d/*.conf
cat /var/log/Xorg.0.log | grep EE
1 Like

Forum kindly sponsored by