X1 extreme i5, so far I could not get bumblebee to work

Dear manjaro forum,

I have an x1 extreme (i5 8300h, FHD version) however so far I did not manage to get bumblebee working, my manjaro OS does not launch after switching to hybrid from discrete in bios.

Initial steps prior to being on manjaro OS:

  • Switched to discrete graphis in the Bios

  • Freshly installed manjaro 18.0.2 xfce alongside windows 10 as dual boot
    (i followed the great guide here in the forums, [HowTo] Dual-boot Manjaro - Windows 10 - Step by Step)

  • Then checked on the graphics driver, and video-linux was default installed.

  • The next step was installing bumblebee + primus and depending packages via pacman.
    (As i am using linux-419 kernel i chose bb-switch linux419 and the corresponding nvidia-linux 419 kernel which were available to choose via radiobutton selection)

  • After installation i followed the steps according to the bumblebee arch wiki article
    (see attached screenshot)

I checked in /etc/X11/xorg.conf.d folder and no xorg.conf file was inside (only the keyboard conf file)

I opened a terminal and inserted:

# gpasswd -a *myusername* bumblebee

and subsequently entered

systemctl enable bumblebeed.service

I rebooted switched to hybrid graphics in bios, saved, chose manjaro in the grub boot loader and then I was stuck at the red Lenovo logo screen with black background.

Any advice on your side what to do ?

Greetings !


1 Like

Thank you very much and sorry I did not find those articles prior to posting.

I will look into those and report back if that solved the problem !

1 Like

Alright, so i followed the steps from: https://gist.github.com/mauri870/5a54e415140875b9150ca31c491811f6

I switched graphics to hybrid in the bios and booted from the manjaro live usb stick,
in the grub bootloader menu, changed the driver to non-free and
added the kernel parameter systemd.mask=mhwd-live.service followed by Ctrl+X.
the system booted however i got the following error messages during the process (see screenshots)

I am not sure if i am supposed to get into the full manjaro GUI after this "fix" or the command line screen.
I was able to get into the command line via tty3.man1 man2

without tty the booting process stopped right at "Starting TLP system startup/shutdown."

The important line is the big red FAILED, not the green OK.

The graphics driver isn't loading and LightDM failed to start.

Unfortunately every Optimus-based laptop is different so you'll have to play around until you find something which works.

Optimus is a complete pain which is why most people switch to PRIME.

If you've got a Pascal-based GPU you won't actually benefit much by using bumblebee anyway - any power useage improvements are marginal, and performance is noticably worse.


instead of those parameters, use nomodeset if your intention is to get the live usb to boot.

if you want the installed system to boot, move grub selector to manjaro and instead of enter hit E , find the word "quiet" and replace it with these parameters separated by a single space.

acpi_osi=! acpi_osi="Windows 2015"
then ctrl+x to boot.

if those 2 dont work, you can try these also:
acpi_osi=! acpi_osi="Windows 2013"
acpi_osi=! acpi_osi="Windows 2009"
acpi_osi=! acpi_osi="Windows 2009"
try including nouveau.modeset=0 to each of them. this is how most are able to get manjaro to boot with optimus laptops, myself included.

1 Like

Prepare BEFORE you try changing video card drivers.
What preparations or research have you done BEFORE starting?
Have you read any Manjaro wiki article or Manjaro forum tutorial?
Please list which ones.

Even now, you may find this useful.

I would suggest you start again from the beginning.

1 Like

should he though? everything is installed but he just ran into the typical black screen that usually plagues new optimus/linux users at first. the correct kernel parameter should be all that is needed to get him booted into a graphical desktop.

that parameter just masked mhwd-live.service and allowed him to continue on ignoring it but otherwise does nothing thats necessary to allow the system to boot properly. no?

1 Like

first of all, thank you guys for the advice,
-> considering your questions, yes i have read the manjaro/arch wiki article
about bumblebee, mhwd, aswell as the manjaro installation article on dual-boot which I stated in my initial post.
And yes I am aware that I should have done more intense research afterall

However I did not anticipate to the fullest extent on how problematic the driver changing would be..

@dglt: thanks i will tryout your suggestions as soon as possible

My purpose is to checkout bumblebee if it has any significant impacts on battery life and overall performance, since it was implemented with that intention

1 Like

From experience: stick to using only the dedicated GPU. You have the option in the BIOS which makes it trivial and you then don't have to faff with weird driver setups or boot options. The 1050ti is Pascal-based so battery life should still be perfectly usable.

1 Like

though.. the Arch way, not with mhwd,
The whole sequence of actions is... at least Manjaro-insane!!
And not following MY tutorial :stuck_out_tongue_winking_eye:

There was a 99% 100% chances for failure!

so he booted fine with nvidia. Then it may not need any grub params (possibly)

Intel + Nouveau

mhwd has several configuration default when installing bumblebee.
So, Arch-way in the beginning and then boot without completing in the Arch-way on bumblebee, or at least using mhwd in the end.. :face_with_head_bandage::face_with_thermometer:

without any sign that it was needed in the 1st place..
Maybe it needs some acpi params, but not until it hangs in a "normal" way.

I suggest a normal boot (no grub params).
If it fails, boot to TTY and check and install/reinstall bumblebee with mhwd.
Then startx and if it fails, reboot. If it still fails, troubleshoot, providing info and logs as in the tutorial (MY :wink:).


Hey there, sry for the delay I had to get other stuff done in the meantime.

Anyhow your advice solved my problem ! :slight_smile:

I completly removed the previous manjaro installation and started anew.
Switching to hybrid in bios and starting to boot from the live usb media and in the grub menu pressing E & adding nomodeset as kernel parameter got me booting into the manjaro GUI and bumblebee got correctly detected !

I then installed manjaro following the initial referenced guide from this forum as dual boot and rebooted again in hybrid mode (first modifying the /etc/default/grub file with acpi_osi=! acpi_osi="Windows 2015" under GRUB_CMDLINE_LINUX and sudo update-grub).

Bumblebee in the installed manjaro os got again correctly detected & installed :slight_smile:
The system runs a definetly quieter now in hybrid mode (fans don't come spinning up as much as in discrete gpu mode).

I still have to get HDMI output to my external monitor to work though & i will report back with the steps if i succeed.

So far i followed the guide in bumblebee arch linux wiki and could detect 1x virtual 1 external display via the intel-virtual-output command however I'm not sure how to proceed next


im glad to hear it worked out. :+1:

there are also more than a few forum threads for this and other bumblebee troubleshooting, only a search away. if however you cant get it to work after doing some research you can create a new thread for whichever issue so this one doesnt get confusing to others who may read it in the future. hope it all gets sorted. take care.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by