Xbox One controller not working (trying to make it work with pcsx2)

Hello,

So I recentely completely switched over to linux and chose Manjaro for it's splendid optimus support!
I however used to use a ps2 emulator (pcsx2) which I installed via the pamac gui installer (AUR v1.4.0). I noticed however, that controller setup is a bit different and now I'm having trouble getting my Xbox One controller to work. It's the only controller I have on hand right now and would love to play some emu games.

What I've tried;

installing xboxdrv and steamos's xpad. I couldn't get either to work, xboxdrv couldnt find my controller and steamos's xpad didn't compile because of missing kernel headers. I don't understand what I need to do to fix this, lsusb picks the controller up after all;

$lsusb
Bus 001 Device 009: ID 045e:02ea Microsoft Corp. Xbox One S Controller

Besides this, I can't install/activate xpad itself, I have no idea how to do this. Sorry for all this, I'm a total Arch noob, but used to be relatively comfortable with ubuntu/debian based systems. I'm not so used to the new package manager and have very little experience activating kernel modules e.g.

System info;

$ inxi -Fxz
System:
  Host: casper-Lenovo-Manjaro18 Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 80SR v: Lenovo ideapad 510-15ISK 
  serial: <filter> 
  Mobo: LENOVO model: Toronto 5A1 v: SDK0J40709 WIN serial: <filter> 
  UEFI: LENOVO v: 0XCN44WW date: 04/12/2018 
Battery:
  ID-1: BAT0 charge: 24.3 Wh condition: 24.6/30.0 Wh (82%) 
  model: SMP L15M2PB3 status: Unknown 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 
  charge: 55% (should be ignored) status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20744 
  Speed: 499 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 501 4: 500 
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 03:00.0 
  Display: x11 server: X.Org 1.20.3 driver: intel tty: N/A 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.2.6 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.045.08-NAPI port: 4000 bus ID: 01:00.0 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 4000 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:6 
Drives:
  Local Storage: total: 353.04 GiB used: 212.82 GiB (60.3%) 
  ID-1: /dev/sda vendor: Samsung model: MZYTY256HDHP-000L2 size: 238.47 GiB 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra Fit size: 114.56 GiB 
Partition:
  ID-1: / size: 224.77 GiB used: 137.86 GiB (61.3%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 203 Uptime: 1h 36m Memory: 7.70 GiB used: 2.74 GiB (35.6%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27

Thanks in advance!

Install the linux headers for the kernels you are running.

sudo pacman -S linux419-headers

If you connect the controller via bluetooth, you might want to read this.

Okay so thanks! - I made some partial progress;

Wired it works now because I was now able to install steam-os-dkms with the updated headers.

Wirelessly it still had issues - it lights up correctly now with the xpadneo drivers, but does not seem to be registered in any games yet (big picture, the emulator or a random game I tried).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by