Xfce autologin broke after installing compton

So i installed compton to remove tearing and to get smoother animations, but auto login broke, now it asks me password every time... wtf ?

Is this an issue report or are you looking for help?

Do you know what could be the issue here ?

Assuming you have LightDM, read https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin

(Also, answering questions can be helpful.)

No, that is not helpful at all. That website doesnt have any information. I am using standard manjaro xfce 17.1.10 installation with updates. I have enabled auto login during installation. Auto login works. I then installed compton, and it broke auto login. There is nothing in that website that would explain this madness. lightdm config is fine, nothing has changed.

Installing Compton doesn't affect LightDM.

Have you tried removing Compton?

Hm, uninstalling it didnt help, but installing it again helped... Linux in a nutshell.

Wait, it was only for one restart, after second restart, its back again to manual login...

let me give you an alternative
use lxdm

sudo pacman -Syu lxdm
sudo systemctl enable -f lxdm.service
sudo nano /etc/lxdm/lxdm.conf

#autologin=dgod

Uncomment it, substituting the target user instead of dgod.

You have to stop and disable LightDM before that command.
And all those commands should be better used after logoff and switched to TTY.

  • Log out of your session
  • At Login screen press Ctrl+Alt+F2
  • Login as your user
  • Run
sudo pacman -Syu lxdm
sudo nano /etc/lxdm/lxdm.conf
sudo systemctl stop lightdm
sudo systemctl disable lightdm
sudo systemctl enable lxdm
sudo systemctl start lxdm

that's not required
as -f is being used which forces it to enable the service

1 Like

Since I don't know if this is the proposed way, I prefer "no-force" actions :wink:
Then I watch the messages and all goes as designed.
Whatever works is fine!

Thanks, it worked. It looks like lightdm is broken, and any change to the system just breaks autologin...

Nope, something still breaks autologin, even lxdm doesnt work, it randomly asks for login... Maybe hdmi external monitor breaks that ? I use a laptop with a monitor that is connected via hdmi.

try reinstalling manjaro

That doesnt really help. At first it might work, or might not work, but later, after installing some random program, that doesnt have anything in common with booting or loging in, autologin just stops working.

install lightdm-settings package its gui

How do you configure autologin? Post the relevant config file, so we see if you missed something.
It is not so sensible that the GPU driver interferes with autologin IMHO.
Maybe you have to describe what exactly happens when you say "autologin failed".

I just install manjaro xfce 17.1.10, and during installation, when you have to choose username and stuff, there is a box that you can check to get autologin, i check that box. Autologin failure means that i get login screen, where i to enter my password manually, instead of automatic login. Also, as i use hdmi monitor instead of laptop screen, login screen is broken (95% of the time) - it uses laptop screen resolution instead of monitor resolution, and the login screen is little window in the corner of monitor, and the rest of monitor is black (720p laptop monitor vs 1440p external monitor), and also login window theme is usually broken too (defaults to standard xfce theme instead of using my theme). Also, very important part is that all of this happens randomly, so my guess is that some programs in manjaro xfce are configured incorrectly, and a few programs are fighting to set various parameters, like autologin, cursor size, login window theme and so on, and every boot a random program executes faster and wins the race to set various settings.

Compton should not interfere with the system (lightdm) but only the session. So, if it is really the source of this problem, it may log you out of session, when Auto-login actually works.
To rule out compton, disable compton autostart.
From TTY (or terminal/Thunar inside your session)

  • Go to Autostart folder
cd ~/.config/autostart
  • If there is a compton.desktop (or similar name) file, edit/add this
[Desktop Entry] {at this section}
Hidden=true

  • Save and reboot

Though I don't think compton is the problem.

You may need to create/edit and enable an Xsetup script for LightDM.

LightDM does not "use" any user's theme (in a multi-user system, how to select which user's theme to apply?). You can configure LightDM theme and others as suggested

If you do all the above and still have problems, you may need to fine-tune your Xorg configuration, driver or other.

Forum kindly sponsored by