XFCE constantly freezes/stutters weirdly after switching back to Bumblebee

For the past day or so, I've been quite frustrated with XFCE. I recently switched back to Bumblebee drivers from NVIDIA PRIME, mainly since I wanted to improve battery life on my laptop. I used the Manjaro Settings Manager to first uninstall the PRIME driver, then install the Bumblebee one. After rebooting, this behaviour started. With notable consistency, everything will be running OK, but the moment I: right click, open the start menu, switch windows, open an application, or receive a prompt, the system will hang for 10-30 seconds with artefacts left on the screen. This seems to be the worst when I try to open the start menu. During the freezing, I can still move the mouse, and sometimes while mousing over things, the mouseover "effects" will still appear. This is extremely weird, and I haven't seen anything like it on the forums or other resources.

Some info:
CPU: Intel Core i7-7500U @ 2x 3.5GHz
GPU: Intel Corporation HD Graphics 620 (rev 02)
NVIDIA GeForce 940MX
OS: Manjaro 20.0.3 Lysia
Kernel: x86_64 Linux 5.6.16-1-MANJARO (I usually prefer 4.19, this is what I'm currently on after switching around)

Things I have tried:
Changing kernels; I have tried every LTS and recommended kernel with little improvement.

I then (biting my tongue) restored to a Timeshift backup from before I even installed the PRIME drivers, figuring maybe some Xorg stuff got messed up or whatever. It was still no help. If my memory serves, everything seemed fine until I rebooted after updating.

I've uninstalled and reinstalled the drivers countless times.

Please let me know what I can do to solve the problem/what logs I can provide to assist. Thank you!

Forum kindly sponsored by