[XFCE] Display settings back to default after reboot - started recently after updates

Also, it happens whether I simply logout and back in or reboot.

Please check if upstream has reported issues for this already. Also check which exact versions of packages might not work for you. We are currently on heavy development for XFCE 4.14 release.

1 Like

As a workaround you could make a startup script which sets the correct settings.

I also started to see a display issue every system start after a recent update..

I posted about it here:

For example I have this startup script:

xrandr --output DVI-D-0 --mode 1680x1050 --rate 60.00 --pos 1920x15 --rotate normal --output HDMI-0 --primary --mode 1920x1080 --rate 75.00 --pos 0x0 --rotate normal --output DP-0 --off --output DP-1 --off

theres been a couple threads in the past few days about this.

i'll link the others in a min, i dont think a permanent solution was found though.

I think this one seams to be similar:
Display settings resolution not saved

1 Like

have you tried what was mentioned as a workaround in this duplicate issue?


Looks like new settings are preserved over reboot/relogin only if a new profile is created. Previously I had no profiles available.

@dglt Thanks! That workaround (creating a Display profile) seems to have fixed the problem.


I think I already had profiles set when it occurred. I'll retest.

Edit: This did not fix it for me. After login when the wrong monitor setup is presented, if I start xfce4-display-settings -m at that moment the correct setting is enabled. If I just start xfce4-display-settings (without -m) nothing happens.

So I re-enabled my startup script workaround.

try removing any existing profiles first, then creating a new one

1 Like

Tested. Didn't work.

Well hopefully there will be a fix in the future.. In the meantime I can live with it (using a startup script).

I guess I could report in the XFCE bug report, but I don't have any more info apart from that it doesn't work for me.

Thanks for all the replies.

Creating a new profile (did not have one before) solved this issue for me.


Thanks a lot. It works after creating a Display profile

1 Like

This issue seemed to be fixed via update Xfce 4.14pre1. I disabled my startup script.

1 Like

This problem is happening again. It's recurred after the latest updates. I tried creating a new display profile for the display settings I have but whenever I reboot it doesn't pick it up.

have you checked the update announcement thread for the most recent updates to see if others are having this issue?

You mean this thread: https://bugzilla.xfce.org/show_bug.cgi?id=15437 ?

no, the manjaro update thread, but that bugzilla link is much more informative. it looks like it will be fixed in the next xfce update? did i read that right?

until then, i guess you can disable the auto enable profiles?

xfconf-query -c displays -p /AutoEnableProfiles -s false

According to that thread it seems to be fixed in 4.14pre3. The latest version distributed by Manjaro is 4.14pre2. The fix in 4.14pre3 seems to be committed to git master so maybe when the next version is packaged by Manjaro it should be fixed. How can I find out when Manjaro will pick up the next version?

what branch are you referring to? im on testing and its only at 4.13.8-2

~ >>> pacman -Ss xfce4-settings                                                                         
extra/xfce4-settings 4.12.4-2 (xfce4)
    Settings manager for xfce
extra/xfce4-settings-gtk3 4.13.8-2 (xfce4-gtk3) [installed]
    Settings manager for xfce

Forum kindly sponsored by