XFCE - QT(?) not scaling, could use some help

Hi

This week it occured to me that I didn't encrypt my drive (which is required by my workplace), so I decided to do a clean install this weekend and just setup everything again. Everything is in the cloud or git so it's not that big of a deal.

I was on Plasma but decided to give XFCE a go since it's the "default" in Manjaro, I was thinking why not. I installed it, everything went great, it's running very smooth but I ran into an issue with scaling for my 4K laptop screen.

There are certain applications/setting windows that I just can't seem to get scaled. I've included a screenshot to show what I mean. The screenshot also includes every setting I changed (based on the arch wiki).

Also noticed that my desktop wallpaper isn't as "crisp" as it was on Plasma, which is weird because it's the same high res image :thinking:

Am I doing something wrong? I've searched through so many topics and wiki's that I'm starting to feel lost :sweat_smile:

Here's a screenshot of every setting I've made: https://imgur.com/Ibi92QA
As you can see on the left, these two windows are so small, they are unusable.

Where and what exactly have you searched to make you feel lost? :slight_smile:
Have you seen this:


This is because they are QT windows. Try to set a bigger fonts size in qt5ct. I would assume 14pt is a good start.

I don't know, I kind of feel like I followed every step on the Arch Wiki and the post I could find about scaling things on XFCE and it's still not as good as I got it in Plasma with the same settings. In Plasma I set the QT scaling var in /etc/environment and it was fixed, on XFCE it has zero effect.

I've tried settig fontsizes, font DPI, ... which was all shotty because it only changes the fonts but not the UI in general. I've changed the value in the QT scaling var from 0 to 1 to 2 and to 1 again and noticed no difference. (@mbod I think this answers your suggestion as well)

There most be something I'm doing wrong that makes it impossible to get this QT stuff to scale but I can't seem to figure out what.

Here is what I have on my 4k laptop:

grafik
grafik

Are you using the same home directory with your new XFCE install as with the previous KDE install? If so, you might want to delete the former KDE settings completely. This should be somewhere in ~/.config

No matter how I change the fonts, it seems to make no difference. I just wish I could get the QT scale env variable to work like it did on Plasma, it's strange that it has no effect.

I did a clean install, removed exiting partitions and made now ones so there's no remains from my previous installation.

I've tried adding it in /etc/environment, .bashrc& .bash_profile and neither works.
I tried setting the fontsize to 16 but that didn't do much either.

I think, now that I'm doing clean installs, I'm going to give Cinnamon a try and if that isn't much better I might go back to Plasma, it's pretty clear that XFCE isn't up to the task of being installed on a computer with a HiDPI.

All the other stuff was so nice though, every time I try a DE there's stuff that I miss on the next one I try :sweat_smile:

Thanks for the effort guys.

Have you tried to make changes in kvantummanager ?

Jup, I tried adjusting the settings over there to no avail. Tbh, I just switched to Cinnamon and everything so far is just working out of the box. I think I'll just stick to Cinnamon until XFCE or Plasma have better ways of handling scaling.

Thanks for trying to help though. It was strange that nothing was working.

edit: ended up going back to Plasma since 5.18 has better scaling. Cinnamon was pretty great though, especially the hidpi support, but Plasma just seems like a better fit for me.

It's too bad I couldn't get XFCE to work as it should, would've loved to try it for a little while longer, maybe in the future.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by