xfce4-display-settings crashes after stable update (2019-08-13)

xfce4-display-settings crashes for me:

[1]    1739 segmentation fault (core dumped)  xfce4-display-settings

I have installed:

xfce4-settings-gtk3 4.14.0-1

Currently I can't reproduce this error. Did you reboot after you upgraded?

@philm @kawasakai Hi, I can confirm I see the same issue when switching from KDE Plasma to see how XFCE 4.14 was these days. I have three screens connected by a Dell 3100 USB3 hub, working fine under Plasma. However, after XFCE install, reboot and log in the xfce4-display-settings only works if I disconnect the Dell hub. With it connected I get the display duplicated on all three screens but the segfault when launching xfce4-display-settings from the terminal. Didn't do too much in the way of further diagnosis, tried twice, same result so I went back to Plasma.


I have the same issue. I have 2 external monitors (1 hdmi and 1 dsub) and laptop's own display. If I try to open xfce4-display-settings I get:

$ xfce4-display-settings
Segmentation fault (core dumped)

Yes I did reboot. Also after Slartibartfast196 reported the error happening only multiple monitors. I tried the same and can confirm it happens only when I have 3 monitors connected.
Having only the internal display connected, the display-setttings open just fine.

Here are my specs with 3 monitors connected:

inxi -GS
System:    Host: kai-tuxedo Kernel: 4.19.66-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.1.4 

Hi. I'm running into the same issue. It started with the first reboot after yesterdays updates.

This are my specs (Internal Notebook Monitor + 2 externals)

System:    Host: jochil Kernel: 5.2.8-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A 
           Display: x11 server: X.Org 1.20.5 driver: intel 
           resolution: 1920x1080~60Hz, 1920x1200~60Hz, 1920x1200~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.1.4 

If the notebook is not connected to other monitors (or the monitors are deactivated) everything works fine

OK, seems to be a bigger problem then.

Would be good to check with upstream about this. Since only a few tested 4.14 during development it might had slipped thru. See also.

What was the last working version you guys know of?

I assume one of the last three display: commits might had introduced the issue.


Please get the PKGBUILD, change to an earlier commit and recompile it. Let me know the culprit to notify upstream.

I did build your package, but it didn't fix it.

pacman -Qi xfce4-settings
Name            : xfce4-settings-gtk3
Version         : 4.14.0-1
Description     : Settings manager for xfce
Architecture    : x86_64
URL             : http://www.xfce.org/
Licenses        : GPL2
Groups          : xfce4-gtk3
Provides        : xfce4-settings
Depends On      : exo-gtk3  garcon-gtk3  libxfce4ui-gtk3  libnotify  libxklavier  gnome-icon-theme  gnome-themes-standard
Optional Deps   : libcanberra: for sound control [installed]
Required By     : None
Optional For    : None
Conflicts With  : xfce4-settings
Replaces        : None
Installed Size  : 3,65 MiB
Packager        : Unknown Packager
Build Date      : Mi 14 Aug 2019 09:53:46 CEST
Install Date    : Mi 14 Aug 2019 09:55:32 CEST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None
[1]    4461 segmentation fault (core dumped)  xfce4-display-settings

Hy I have the same problem.
xfce4 4.14 crashes display settings with 3 displays (1 edp: the notebook screen).
It works with only one external display but crashes immediately when I connect the 3-rd one.
Downgrading to xfce4-session-gtk3-4.13.4-1-x86_64.pkg and xfce4-settings-gtk3-4.13.8-1-x86_64.pkg solved it for me.

iinxi -GS
Host: thinkpad-x240 Kernel: 4.19.66-1-MANJARO x86_64 bits: 64
Desktop: Xfce 4.14.1 Distro: Manjaro Linux
Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting
resolution: 1366x768~60Hz, 1920x1080~60Hz, 1024x768~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.1.4

Did you changed the commit to an earlier than 4.14.0 tag?

Also upstream told me this.

Hi Philip,

could you ask your users to run xfce4-display-settings through gdb to get a backtrace?
Otherwise I'm not sure, I can't reproduce the problem here.

Also make sure to file a bugreport upstream: bugzilla.xfce.org


Sry, I missed to downgrade in my previous post.

I did now, but still:

% xfce4-display-settings
[1]    1770 segmentation fault (core dumped)  xfce4-display-settings
% xfce4-display-settings -v
xfce4-display-settings 4.13.8git-d2ad11 (Xfce 4.14)

See in our history on how we changed the commits

If there is one of our packages working, let me know. So far 4.13.8-1 is confirmed, which is upstream this commit, please double check and maybe do a git-bisected starting with the last working version.

working here:

xfce4-display-settings -v
xfce4-display-settings 4.13.7git-ea6efe (Xfce 4.14)

Is that the first working one? Please do a git-bisect by cloning the upstream git repo and start with a working commit sum. Build the package with that sum and confirm. When you get a new sum string change it in the PKGBUILD and rebuild. Repeat the process until you have the culprit of the issue.

I went to far. 4.13.8-2 is the last working for me.

Maybe this is a little over my head, I don't see 4.13.8-1 in the git repo.

I never used git bisect before and I have some trouble figuring it out. That is how far got:

* 0320df9 - (HEAD -> master, origin/master, origin/HEAD) [pkg-upd] 4.14.0-1 (3 days ago) <Philip Müller>
* 990875d - (refs/bisect/bad) [pkg-upd] 4.13.8-3 (4 days ago) <Philip Müller>
* ccec7d8 - (refs/bisect/good-ccec7d8234b2371905ff21f9a965d0d51ef1c09d) [pkg-upd] 4.13.8-2 (10 days ago) <Philip Müller>

same here, clicked in settings it hangs and in the terminal i am getting: "Memory access error (memory dumped)" translated from ger to en.

nvidia native drivers
3 screens, left and right both 4k 60hz and in the middle 2560*1440@165hz.

i am on stock arch, btw.

OK, seems we miss read each other.

Please do a git bisect on this repo. Based on your review the commit d403bc6abc9bd49b9f95d1ba647fe112519597dd is the working one. Upstream there are many more made. After git bisect offers you a new commit string, please replace commit=d403bc6abc9bd49b9f95d1ba647fe112519597dd with that new one in the PKGBUILD and recompile. Follow git-bisect process until you find the offending upstream commit so we try to find a proper solution upstream.

You may follow my bisect of linux41 back in the days.

09bdf5d1118b9ba8ce48fb8cf4528f024b218be2 is the first bad commit

Workaround: switching off one of the 3 monitors (the one connected via hdmi) temporarily solved the problem for me.

Forum kindly sponsored by