xfce4 resetting on logout/sleep

If I leave my computer for some time when I get back to my computer all opened windows have been reset (because I have been logged out). There are a number of options in "Session and Startup" such as "Automatically save session on logout" that should theoretically work with "Display chooser on login" but doesn't wfm.

What does show after logging in are 2 new terminals, not sure what is actually telling these to open but might have something to do with my problem?

I'm running an optimus setup

System:
  Host: leraz Kernel: 5.6.16-1-MANJARO x86_64 
  bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 
  info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 

Seems to be working now, not sure why but I'm able to keep the state of my open windows with the session settings I mentioned

Welcome to the Manjaro forum @lwingr!

Are you actually being logged out after a time of inactivity?

It sounds weird, so I took a look through my own XFCE settings - and I am unable to find any way to make that happen to me, so I suspect there's something else going on than just normal configuration using the GUI tools.

A couple of questions:

  • Is it an old install, or did you just install?
  • Have you been doing any funny business that you know of?

I suspect maybe your computer tries to hibernate and then crashes, so could you please start Power Manager and change the system sleep mode to Suspend if it is Hibernate? If it's already Suspend, then try to set the timer to Never.

To do a quick test, by the way, try to set the laptop lid action to hibernate and suspend and close the lid, give it some time and open the lid again. When set to hibernate it takes some time, but suspend should be fairly quick. If I'm right the PC will crash and restart. If I'm wrong it's something else :grin:

Thanks for helping @Ferdinand !

I'm not sure it was logged out or simply locked BUT I can't replicate the issue by locking the screen manually, or closing the lid like you mentioned. I do have a workaround with sessions now working, but there is another related problem of losing display settings when the laptop is inactive for a short while or logged out - the displays become mirrored and I have to set them back each time, regardless of what my display or session settings are.

Installed about a week ago. The only funny business has been my external monitor working with optimus-manager, and tinkering with various settings in "display" and "session & startup".

Have just set the suspend timer to never so will report back if that changes anything.

I did your tests and suspend didn't cause the displays to mirror, in fact the only way to replicate seems to either leave for a while or logout. When Hibernating instead, power manager errors "Not enough swap space".

Hm. If you close the laptop to make it suspend, and then it continues fine when you open the lid, then suspending is not part of the problem.

Similarly, if you get that error when trying to hibernate, and the computer continues after you open the lid, then hibernation is not the problem either. The error just means you installed without hibernate support (in order to hibernate it needs reserved disk space to store all memory to disk, and it's a question during installation I believe) which is fine - hibernating is useful only if you can't turn off the computer for some reason and go for extended periods without access to power.

In effect, I no longer think your computer fails during suspend/hibernation and reboots. Which means there must be something else wrong.

It may be relatedto the NVIDIA driver - or maybe something about that optimus manager, which I don't know much about, but here's som info from @philm, who do :smiley:

By the way, as suspending seems to be working fine, I would reset that timer to something sensible, at least for when you run off the battery - I use 10 minutes.

Changing the System sleep mode to never has resolved the issue, many thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by