Xiaomi Redmi Airdots Have Bad Sound Quality on Manjaro

Hello, I can successfully connect my airdots via bluetooth but the sound quality very bad. It is like I'm listening the sounds in an empty room.

I have no idea how to imagine by your description. But please check whether it uses A2DP profile instead of HSP/HFP.

When I select A2DP, it turns to HSP automatically after when I increase or decrease sound level.

That would be useless, it's the bluetooth profile that's problematic. But I have no idea how it could switch from a volume change.

it's a bug of manjaro since months ago. No idea why they have not addressed yet...
The workaround is to reset the bluetooth service with
" systemctl restart bluetooth"
With that you can power on the bluetooth and when selet AD2P you are going to hear much better quality of audio.

this is probably not true, I am sure that the profile didn't change at any time so with change volume the profile is only showing the real state after the try to change.

it has no sense here since the problem is the profile I think...

Switch between HSP/HFP and A2DP setting

This can easily be achieved by the following command where the card_number can be obtained by running pacmd list-cards .

$ pacmd set-card-profile card_number a2dp_sink

For enabling automatic profile switching from A2DP to HSP when a recording stream appears without any role set, you can append auto_switch=2 to load-module module-bluetooth-policy in /etc/pulse/default.pa .

For more information about PulseAudio profiles, see PulseAudio Documentation
do the math

it is not true. The ad2p switch has errors since months ago. You can swithc from command, trrhought what you want for example plasma but there is an error that make that connection fail and fallback to hsp( or ad2p in some cases), you have to make bluetooth systemd service reset.

This must be either installation specific or device specific, as it doesn't happen to any of my bluetooth speakers (Mifa A1, A10, A20) and headset (Bluedio T4S, QCY QS1, QCY QS2), could also be adapter specific. You should try isolating the problem source, at least by testing with other bluetooth audio devices.

I have one bluetooth device that don't give me those problems and other ones that give me. It has to be for problem specific with profile. But restarting systemd service fixes all my problems, so not a devide specific problem but a manjaro ones.

I have 2 laptops and 1 desktop all of them with differents bluetooth cards so.. yes, it is not devide specific it's a manjaro ones.

have you a " usual" plasma 5 manjaro instalation? Or do you have some specifics things like to disable bluetooth in systemd services and starting only when needed?

Nope, even instead of having less, I have more services enabled. Never have I turn off either bluetooth or wireless. My PulseAudio is also bridged to JACK for my recording needs.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by