Xiaomi Redmibook 14 Ryzen Edition issues

Hi everyone! Recently I got Xiaomi Redmibook 14 Ryzen Edition with Ryzen 7 3700U on the board. In Windows all works fine, but in Linux (I also tried Kubuntu 19.10) there are two main issues: FN keys don't work absolutely, neither WiFi module (I can't even post inxi -Fxxxz in the text mode :frowning: ) Additionally on Manjaro screen dimming works weird (not smooth at all) and battery didn't recognized. I'm sure that problem is in AMD drivers, because Intel version of this notebook got all FN keys working on Arch or Ubuntu. Any suggestions? Thanks!

Dummy inxi -Fxxxz, sorry for that :frowning:
MVIMG_20200226_233945

1 Like

:+1: Welcome to Manjaro! :+1:

You're on very new hardware, so Manjaro is the correct distro for you, but we're dependent on the Linux kernel to catch up and you're currently on the stable 5.4.18 LTS (Long Time Support) Linux kernel version.

You have 2 options:

  • If you're a hacker¹, you might want to switch to our testing or unstable branch.
  • If you need this machine to do actual work, I'd advise you to install the 5.6RC3 kernel which is not the default for the stable branch but which might give you more versatility with your hardware...

:innocent: :+1:

Note 1: Hacker in the positive sense: Hacking things together, unlike cracker which is taking things apart. :innocent: :wink:

Got FN keys work on 5.5 kernel, but WiFi isn't working. I think I should create a new topic :slight_smile:

1 Like

Hello, how did you do to get FN key working?
Wifi network works fine followinf these steps: [SOLVED] Atheros QCA6174 - Intermittent WiFi Failure (Dell XPS 9560) - Technical Issues and Assistance / Networking - Manjaro Linux Forum

He upgraded his kernel from 5.4 to 5.5. Please post another question for your particular use case as this question is solved and you'll get more :eyes: on your new issue if you post a new question!

:innocent:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by