.xinitrc seems to don't get loaded at startup

Hello here,
I created a .Xresources in my home folder, to customize rxvt-unicode.
I already read this topic, but I don't understand what they did in the solution.
I checked the .xinitrc, it is the default file present on my installation, and it check if a .Xresources file is present in my home, and load it.

userresources=$HOME/.Xresources
[some bash here…]
if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"
fi

If I did the command xrdb -merge manualy, the file is correctly loaded, and urxvt change !
Those lines should load my file, I think.
I tried to add this line at the begining of the .xinitrc:

echo "test" > $HOME/test.txt

And the file is never created.
I think my .xinitrc is never called anywhere.
I use GDM as login manager (I use gnome).

Maybe have a look here:

https://bbs.archlinux.org/viewtopic.php?id=184435

Thank you for the link.
I followed instructions, but it doesn't work.
But, it was a start for some research, and I found a solution:
remove the -nocpp option of /etc/gdm/Xsession file, at the line:

xrdb -nocpp -merge "$userresources"
1 Like

I use this for my xterm, inside .xinitrc:

[[ -f ~/.Xresources ]] && xrdb -merge -I$HOME ~/.Xresources

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by