Xorg can't find GLX for Nvidia

Hello !
After installing Nvidia driver "video-hybrid-intel-nvidia-390xx-bumblebee" on my HP laptop, I'm not able anymore to log to my session with Gnome. Grub is working fine, but I can' go further with GUI. I manage to acces my PC with TTY with Grub option "3" instead of "quiet splash"
I got help from french forum www.manjaro.fr and the guy advice me to post here as my situation is tricky...
The thread title was given as an explanation of the French forum, and I guess it should be a conflict :zipper_mouth_face:
I'm quite new to Linux and I would like very much to get the Nvidia card working
here is the return of inxi -Fxxx (berore Nvidia driver install):

System:
  Host: probook Kernel: 4.14.47-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.0 Desktop: Gnome 3.28.2 info: gnome-shell dm: gdm 
  Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:
  Type: Laptop System: HP product: HP ProBook 450 G5 v: N/A 
  serial: <root required> Chassis: type: 10 serial: <root required> 
  Mobo: HP model: 837D v: KBC Version 02.2A.00 serial: <root required> 
  UEFI: HP v: Q85 Ver. 01.02.04 date: 01/30/2018 
Battery:
  ID-1: BAT0 charge: 23.5 Wh condition: 45.5/45.5 Wh (100%) volts: 11.2/11.4 
  model: Hewlett-Packard Primary type: Li-ion serial: 11200 2018/01/30 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 10 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
  Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 5: 700 6: 700 7: 700 8: 700 
Graphics:
  Card-1: Intel UHD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:5917 
  Card-2: NVIDIA GM108M [GeForce 930MX] driver: nouveau v: kernel 
  bus ID: 01:00.0 chip ID: 10de:134e 
  Display: x11 server: N/A driver: nouveau compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.0.4 compat-v: 3.0 direct render: Yes 
Audio:
  Card-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k4.14.47-1-MANJARO 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: 3000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: 10:e7:c6:db:82:af 
  Card-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus ID: 03:00.0 chip ID: 8086:24fd 
  IF: wlp3s0 state: up mac: 74:e5:f9:09:69:f1 
Drives:
  HDD Total Size: 465.76 GiB used: 10.00 GiB (2.1%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO M.2 500GB 
  size: 465.76 GiB speed: 6.0 Gb/s serial: S33DNX0J703069N rev: 1B6Q 
  scheme: GPT 
Partition:
  ID-1: / size: 76.40 GiB used: 9.99 GiB (13.1%) fs: ext4 dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 35.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 244 Uptime: 1h 20m Memory: 7.69 GiB used: 1.22 GiB (15.9%) 
  Init: systemd v: 238 Compilers: gcc: 8.1.0 Shell: bash v: 4.4.19 
  running in: gnome-terminal inxi: 3.0.10 
[philippe@probook ~]$ 

I follow advices given and remove video-linux driver before Nvidia install, then nex reboot was painful for me :cold_sweat:
Since that time I manage to install kernel 416 and 417 but not luck with it

Here is the return of the following command lines I manage to take:

sudo journalctl -b0 -u bumblebeed
sudo journalctl -b0 | grep nvid
sudo cat /var/log/Xorg.0.log | grep (EE)
dmesg | grep -C 10 bbswitch
sudo systemctl status bumblebeed

http://pix.toile-libre.org/upload/original/1529231538.jpg
http://pix.toile-libre.org/upload/original/1529231674.jpg
http://pix.toile-libre.org/upload/original/1529231699.jpg
Sorry for the pictures, but i got no other way
Any help/advice will be appreciated.

You have the nouveau driver, the free one installed. So whatever you did, is not the correct driver there.
First do this:
sudo mhwd -r pci video-hybrid-intel-nouveau-bumblebee
then
sudo mwhd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Also make sure you read this even if is for the video-hybrid-intel-nvidia-bumblebee

1 Like

Thanks, but I mention inxi was done before installing Nvidia driver. Sorry if it is not clear.
I've read the tread you mention here, but not the case for me, I think

You had 4 edits ...
Anyway, moving on ... how did you installed the drivers? Nevermind ...
Probably this is what you are looking for

1 Like

Yep, I got problems with the pic links and had to edit is several times. And I could not copy the screen as text
The thread you mention is not understandable for me, I'm a beginner and don't know what is lightdm, GDM...
The french guy told me I will works with "primusrun' instead of Prime, as far as i know...
Drivers was remove and installed this way :

sudo mhwd -r pci video-linux
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

"thefrenchguy" hein ?
:wink:

can you report

sudo pacman -Qs nvidia
sudo pacman -Qs nouveau
sudo pacman -Qs nvidia
sudo pacman -Qs nouveau

http://pix.toile-libre.org/upload/original/1529268266.jpg

Use gist to copy/paste output to a file/pastebin service. Read how:

Then, on TTY try

startx

If it fails, take a photo of the error message.
Then try

sudo systemctl restart gdm

If there is no login screen, then send these to gist (command > gist command)

cat .local/share/xorg/Xorg.*.log
cat /var/log/Xorg.*.log

Glad you help me, I already tried startx 2 days ago and I got black screen for 1 second and it came back to TTY with some log. See here:
image startx

sudo systemctl restart gdm

Black screen and Ctl+alt +F2 to get login prompt again

I tried but I could not manage to get 'gist' working. What command should I write after gist ?

cat .local/share/xorg/Xorg.*.log > gist ???

Thank you

Forget about it for now (I will modify the tutorial) and use wgetpaste

sudo pacman -S wgetpaste
inxi -SGxx | wgetpaste
ls -Al | grep -e "^-r" | wgetpaste
cat .local/share/xorg/Xorg.*.log  | wgetpaste

You may have serious problem with your user folder (No .Xauthority ? ).
Create a new user and try to login to that and startx

1 Like

It's workin'

inxi -SGxx | wgetpaste

https://paste.pound-python.org/show/NnntnUeCWlipYmSgveXt/

ls -Al | grep -e "^-r" | wgetpaste

https://paste.pound-python.org/show/yjmOJf3ToCJPnWRK3jL0/

cat .local/share/xorg/Xorg.*.log  | wgetpaste

https://paste.pound-python.org/show/gMA1EUOpH3ZN2oAZw3VA/

I have to check how to create new user via command line... Hold on :thinking:

Could not create new user !

useradd -g users -m -s /bin/bash phil
Mot de passe:
useradd: Permission denied
useradd: cannot lock /etc/passwd: try again later

tried also w/ sudo useradd -g...

ls /home/
phil  philippe

So I've create the phil home folder, don't kwow what to do next...
Edit : Same problem with new user 'phil"


[phil@probook "]$ startx
xauth: file /home/phil/.Xauthority does not exist
xauth: file /home/phil/.Xauthority does not exist
... (and full screen error  message)

Edit #2: I give up! disable Nvidia GPU and install Manjaro from scratch :flushed:

i have discuss with his troubles on the laptop:
he tries iso Gnome and Xfce 17.1.10
on install no trouble video , but each time after upgrade lost intel video.

we have try nvidia with bumblebee , but failed with glx with Xorg 1.19.6

in case of Gnome we do not find log ( no more gdm-g-cession died ), also for Xfce , only xorg and no more Xorg cession died , before on login

only fallback can start , but on next reboot same trouble

in this case , no more update before finding whats happens

Hi connunity !
Finally, I give up with Nvidia and disable it in bios.
So I start again from scratch with 3 partitions, one for Gnome, one for Xfce and the last one with Deepin. But I still got troubles, I cannot go further than Grub, no GUI at all except first boot after install.
Here are the returns I was advice to run in TTY in order to to find the culprit (Manjaro Linux 17.1.10 w/ kernel 4.17, but I did not apply the updates after the first reboot):

philippe@probook ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI
Warning: No installed USB configs!

(Same as before)

sudo inxi -Fxxxz | wgetpaste
https://paste.pound-python.org/show/2q6E1lzOenGq5OiKpTgR/

systemctl --status display-manager | wgetpaste
https://paste.pound-python.org/show/No2HnqSZNx8ifmok0vI0/

sudo mhwd-gpu --status | wgetpaste
https://paste.pound-python.org/show/s9cLGfujxpUcE0G9sZJ9/

philippe@probook ~]$ sudo systemctl status sddm.service
Unit sddm.service could not be found

cat /var/log/Xorg.0.log
https://paste.pound-python.org/show/rNJnXhc83ovL0uMQZ6Bp/

There is 2 errors( from line 85):

[     5.486] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.486] (II) LoadModule: "vesa"
[     5.486] (WW) Warning, couldn't open module vesa
[     5.486] (II) UnloadModule: "vesa"
[     5.486] (II) Unloading vesa
[     5.486] (EE) Failed to load module "vesa" (module does not exist, 0)

sudo journalctl -b0 | wgetpaste
https://paste.pound-python.org/show/IGd4iuWzlHTreXgnsoLu/
Stéphane mention here Error EC (line 318)

juin 27 21:52:19 probook kernel: ACPI: EC: EC started
juin 27 21:52:19 probook kernel: ACPI: EC: interrupt blocked
juin 27 21:52:19 probook kernel: ACPI: \_SB_.PCI0.LPCB.EC0_: Used as first EC
juin 27 21:52:19 probook kernel: ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x6e, EC_CMD/EC_SC=0x66, EC_DATA=0x62
juin 27 21:52:19 probook kernel: ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions

And finally:

philippe@probook ~]$ startx
.../...
xf86EnableIOPorts: failed to set IOPL for I/O (operation not permitted)...

I took a screenshot, but startx fail

Doing update-grub doesn't help to reboot neither

Hope it can help to find a solution

You're using the latest generation Intel powered laptops/notebooks, I guess. People seems to having some trouble with it. Can't boot Manjaro on Intel/NVidia setup, can't use Xorg

If that so, set everything on default settings and test boot with acpi_osi=! acpi_osi="Windows 2009" or acpi_osi="Windows 2012" (if you having trouble with touchpad). If it works then make it permanent.

1 Like

Thanks a lot SDN !
The Topic you mentioned is very interesting. and the Github save my day !
For my HP Probook 450 G5 the good Grub options is acpi_osi=! acpi_osi="Windows 2012" as I just boot fine with :hugs:
With "Windows 2015" fans was at full speed and trackpad disable
With "Windows 2009" system do not boot
Not tested with 2013 yet
Now I have to check if everything runs smooth, mostly power supply fonctions, as acpi modify the way the system handles it AFAIK

I don't know if I was right to disable Nvidia card in bios as mentioned in the Arch wiki (but don't know who succeed to install Arch on the same laptop as mine :disappointed_relieved: )
But Nvidia card is still disable

1 Like

Glad to know that your laptop is up. :grin:

But, anyway, that Arch wiki doesn't say anything about disabling nvidia card. Why don't you try installing nvidia driver and bumblebee as stated in this manjaro wiki: https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup (Edit: keep the nomodeset parameter just in case)

After installing the driver you can run primusrun glxgears and carefully watch you laptop CPU and GPU temperature, fan and voltage. Yes, glxgears is enough just to test if there are irregularities to those statuses with acpi_osi.

Well, well....
I forgot to mention I installed yesterday Manjaro Linux Xfce 18 beta 3
Laptop freeze again at reboot today. Grub options were fine for 2 reboots, but the third one was a real black screen with full fan speed. Between 2nd and third reboot I did some updates (arournd 37 Mo) and a successful test of sleep and return to sleep.
Don't known what's going wrong.
I got no swap set but 8 Go Ram ship, could it be the missing swapfile ? Even after a reboot ?

Do you made those boot parameters permanent?

If you suspect swap file is the culprit, which I doubt but you do need it, then make one.

Edit:
Just to make sure, you need to edit this file /etc/default/grub. Add nomodeset acpi_osi=! acpi_osi="Windows 2012"inside the quote marks in GRUB_CMDLINE_LINUX="" and run sudo update-grub

Edit again:
Please use Manjaro 17.1.10. Using beta version to troubleshoot is risky. And if after you make your new boot parameter permanent in Manjaro 17.1.10 your xserver still crash, watch your /var/log/Xorg.0.log and or journalctl for any error.

Edited again:
You may want to remove acpi_osi=! too. I saw in your xorg.0.log that your laptop use oem osi. acpi_osi=! block that oem osi. so your new boot parameter should only nomodeset acpi_osi="Windows 2012" to enable all and add win10 specific onboard patches.

yes of course ! But I had some hardship with writing "...'window 2012'" [single one, then double quotes] at the end of the line with nano. Otherwise update-grub would not accept it. I hope it is correct. At boot time, when I ask to edit grub file, it's seems correct though.
I did not try yet nomodsetparameter

Thank you for all theses advices. I'll be back and inform you after Manjaro 17.1.10 re-install

Your new boot parameter should be like this;

GRUB_CMDLINE_LINUX="nomodeset acpi_osi=! acpi_osi='Windows 2012'"

or this if you want to enable _OSI(Linux-Dell-Video) oem osi.

GRUB_CMDLINE_LINUX="nomodeset acpi_osi='Windows 2012'"

Forum kindly sponsored by