Xwayland ignores keyboard layout changes

When running gnome with wayland, keyboard layout switching does not work in xwayland applications such as firefox or thunderbird.

A workaround I have found is to run setxkbmap with the same layouts, variants and switcher as is setup in gnome. But I'd like to get a more permanent fix.

I tried "localectl --no-convert set-x11-keymap us,ca pc104 ,multix grp:super_space_toggle" which creates a /etc/X11/xorg.conf.d/00-keyboard.conf file with those parameters, but that file seems to be ignored by xwayland.

For reference, here is the file:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ca"
        Option "XkbModel" "pc104"
        Option "XkbVariant" ",multix"
        Option "XkbOptions" "grp:super_space_toggle"
EndSection

The only related error I can find in the logs is:

gnome-shell[2263]: The XKEYBOARD keymap compiler (xkbcomp) reports:
gnome-shell[2263]: > Error:            Key <MDSW> added to map for multiple modifiers
gnome-shell[2263]: >                   Using Mod3, ignoring Mod5.
gnome-shell[2263]: > Internal error:   Could not resolve keysym XF86FullScreen
gnome-shell[2263]: Errors from xkbcomp are not fatal to the X server

But I am not sure how it affects the whole process. For reference, the version number of a few relevant packages:

xkeyboard-config 2.29-1
xorg-xkbcomp 1.4.3-1
xorg-server-xwayland 1.20.8-1
gnome-shell 1:3.36.1+31+ga6783692c-1

How can I fix this problem?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by