Yaourt can't pass through proxy to AUR

Hello first, thank you in advance
I am having problems with the configuration that I should have to be able to use yaourt to cross the proxy that I have and reach AUR
see this:


but pacman works, I've set the environment variables in Wget see this:



Generally speaking, pasting the items as text is far easier both for you to do and for others to read.

As it is now, if I want to check a specific line I have to watch the entire GIF over and over and make sure I don't blink and miss it - if the GIFs even loop, otherwise I have to reload the page several times.

In terms of the issue I'd recommend a quick web search for "yaourt proxy" and see what turns up.

I'd also advise you drop yaourt in favour of a maintained helper, e.g. yay or pamac.

1 Like

Thank you very much for the advice I will continue

1 Like

I'm a little frustrated because I tried and I can not find how to configure yay so that my proxy goes through this is what returns me:



Besides that I am an ignorant I do not find anything. please be aware of the subject that illuminates me please

1 Like

Unless there is no alternative, do not post terminal output as a pic.

Please post all terminal command output as text with code tags.

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

From https://github.com/Jguer/yay/issues/701 you will need to export your proxy variables:

export https_proxy=http://proxyhost:proxyport
export http_proxy=http://proxyhost:proxyport

and in /etc/sudoers set:

Defaults env_keep += "ftp_proxy http_proxy https_proxy no_proxy"

and if I have authentication against the proxy??

I'm sorry it will not happen again

Something like this should work:

export https_proxy=http://username:password@proxyhost:proxyport
1 Like

then I also edit in /etc/wgetrc
and /etc/pacman.conf ??

Maybe. Try each bit in turn until something works. :wink:

jajajajajajaja ok
I'll try

1 Like

Already configure in
/ etc / wgetrc
/ etc / sudoers
and he returns this to me:
Get https://aur.archlinux.org/rpc.php?arg[]=libnm-gtk&type=info&v=5: Unauthorized

1 Like

I recently did a search with yay in AUR and it returned this to me:

Error during AUR search: Get https://aur.archlinux.org/rpc.php?arg=majaro-lts&type=search&v=5: Unauthorized
Showing Repo packages only

what variables does yay take to know which proxy it has to cross and with what credentials (usre / password)

The two environment variables http_proxy and https_proxy.

In /etc/wgetrc ?

yay doesn't use wget

then it is based on the pacman configuration

dont worry, ja i know you do not worry but thank you I found the solution
Thank you

when I tried to update the repos of AUR it shows me this message

$ yay
:: Sincronizando las bases de datos de los paquetes...
:: Iniciando actualización completa del sistema...
...el sistema ya está actualizado.
:: Searching databases for updates...
:: Searching AUR for updates...

-> Missing AUR Packages:  libnm-gtk
 there is nothing to do

and when I try to install the lost package shows me:

yay -S libnm-gtk
Get https://aur.archlinux.org/rpc.php?arg[]=libnm-gtk&type=info&v=5: unexpected EOF

Forum kindly sponsored by