You are in Emergency mode (How to leave and stay out of the ER)

It is going in to a GUI start now eventually.
I was waiting a while... think the timer was up to 3 minutes?!

First came the "Knight Rider" back and forth for a while.
Then it was sitting and so I tried tty2. CTRL-ALT-F2 had no impact.
I just waited longer and it eventually came to the GUI login screen screen.

I know something is wrong because no other OS has taken this long to boot, and this is an SSD drive, so my expectations are framed in seconds, not minutes.

Here is a shot I took while waiting on it:
Google Photos

I do appreciate the help @mbb.
What can I check next please?
Should I do the 3-lines in the terminal still to give you information?


@mbb I have done these lines:

journalctl -xe -p3 -b
cat /var/log/Xorg.0.log | grep EE
systemctl status haveged.service

I am not sure how to get you the output so I am posting a picture below for now and maybe you can tell me what else to do to get you information.

Firstly, one time a reboot will work and then it will stop and fail. I hate intermittent as it is hard to diagnose. But that is when I know what I am doing and how to look. Here, I am a noob!

Just for a reference, it is still taking over 5 minutes to boot... and the Knight-Rider red asterisk keeps going back and forth, then will move on, then start again.

Eventually, when I think it is locked up, with no HD light indication, I will do a CTRL-ALT-DEL and the screen will flash a few lines and reboot.

This last time I went into tty2, back to tty1, then to tty2 and gave the commands. I wasn't sure how to parse them and give them so I had to try and retry.

Right now I am setting in Emergency Mode again.
Please help me stabilize this system. Or, if I must reinstall, I guess I need to know that too!

I go out of town on Tuesday, and will be gone for a few weeks. There is no way I could talk my wife into doing all of this if I need remote access to this work machine, so I want to try and get it fixed now.

Thanx for your help.

Google Photos
Google Photos
Google Photos
Google Photos

Looks like your drive is dying or there is connection or power issue from the motherboard to your SSD.
You might need to check on the cable connection of your drive (if any) or in the worst scenario you might need to replace it and hope the data on the disk are still salvageable.

1 Like

If you mean "reboot with a button on your PC", instead of using your system's reboot action buttons/commands, you have to make it clear, as it would probably be your problem.

Anyway on boot, use the fallback kernel image, to see if it boots correctly.

But since you disabled fsck check (in fstab to 0) and the errors went away, then it seems this

You might do a manual fsck check or S.M.A.R.T. check if available.

Copy and paste in your post (in code format, use ``` in the lines before and after the output text.)

1 Like

@AgentS I know this sounds silly to you, but I don't understand how to copy what is on the textual screen before booting into the GUI, in order to paste here.

When I am in terminal, I could do a SELECT / CTRL-C to copy, but I cant get to this thread in my browser so not sure how to CTRL-V to get it here.

When I am HERE, in a GUI environment, I don't know how to look at what I saw previously in the Terminal as I was booting!


Seriously, I know this must seem silly. At least I know it can be amusing for those who know this stuff very well. Why? Because I am amused at similar things in subjects I know well.

Anyway... beyond responding to what I have typed above, please tell me about doing an fsck? and SMART check?

This is a new SSD drive 860 Samsung.

Two things I know for sure:

  1. Early this morning the house had a power-blip. I had to restart or turn on many appliances.
  2. In the past 2 weeks this drive has been wiped and has seen fresh installs (repartitioned and formated) of Kubuntu, Linux Mint, and Manjaro.

2 indicates to me that it is not the drive, though I have seen them fail at any time in my windows world experience.

I would like to figure this situation out, if you all will continue to try to help. I think it is important so that I understand more and so that I feel comfortable in trusting the OS install.

Standing by.... but I am going to shut down and check connections, etc.... Will also see if I can figure out how to do the Smart check. The fsck I will wait on , for specific instructions.... seems the wrong arguments can thrash a drive!?!?

Lastly, If I get to the point that a fresh install is needed. Can I just move /home directory into an external then put it back? Or should I handle it differently?

I have Timeshift running, but RSYNC to this same drive... and I also have a USB stick with FileZilla I once used to make an IMAGE of a system. I will want to reload my apps and reconfigure the File Manager settings anyway, so I think my only concern is /home docs and files.

Let's see if we can get this fixed though. It will show me how and be encouraging!

NOTE: I went to install GSmartControl to try to do a SMART test, and I get this:

Warning: lib32-systemd: local (243.9-1) is newer than multilib (242.108-1)
Warning: systemd: local (243.9-1) is newer than core (242.108-1)
Warning: systemd-libs: local (243.9-1) is newer than core (242.108-1)
Warning: systemd-sysvcompat: local (243.9-1) is newer than core (242.108-1)

Not sure it is significant, but wanted it in this post in case.

Oh! Updating this post...
@AgentS You had asked specifically about "hard reboot" and suggested using the "fallback kernel image"...
When I say hard reboot, I mean SHUTDOWN versus RESTART. I guess, since I was immediately shutting down and then trying to boot back up, I miscommunicated with "hard reboot". What I maybe should have said was that I used the menu selections to shutdown, and then restarted after the main unit went silent and dark.

For the fallback, is that when I get a selection between Manjaro and (I can't remember the other option) that counts down during a startup?

You folks must get awfully tired of these noob questions! Thanx for persevering!

It is not silly. It is that you haven't done the basic homework, while you decided to go with a rolling release distro. But don't worry, you are not the first that does that. Here:
How to provide information about your issues
How to change video drivers or configuration and troubleshoot section Log your troubleshooting info in a file
Not the booting messages, of course, but in TTY (after logging in to the "black screen").

From Archwiki on fstab

<fsck> sets the order for filesystem checks at boot time; see fsck(8). For the root device it should be 1 . For other partitions it should be 2 , or 0 to disable checking

Meaning, the partition is still checked on boot. You disabled it with 0 and it went on, so it seems there is possible a drive error.

This is from the package installation process and is not fatal. Have you completed Gsmartcontrol installation? Do it and check the drive.

systemd was downgraded in Testing. So, you are a Tester!?? Nice!.. :face_with_raised_eyebrow:

In "Advanced options for..." submenu, options with "(fallback)".

Now you see why it is a good practice to use a separate partition for your home, unless you ask only for a different disk.
If the target partition is ext4, even copying the users folders (including hidden files) should be enough. Rsync is a good choice, if you can use it for the job.

As it is a brand new installation, yes. Unless you have made several system files changes (grub, Xorg etc) then you should backup /etc as well. I would also backup (and re-use) downloaded packages (/var/cache/pacman/pkg), but you're not me :wink:.

I hope you fix your drive and hopefully the errors.


Awesome response.
I am going to go read those things in a second. I am betting I have before, but now I will understand more of what I am looking at. (Sometimes the eyes glaze over!)

SSD Scanned good!
But before I do, I wanted to respond that YES, I did install and the big/deep scan took until just now, and responded that all was good. No problems. I did save that file.

um... not intended, although in another thread you will see I did mistakenly install a release candidate, so perhaps that is why I have that? I need Stable. Put me there until I find my way around! In the thread it said that since this is a rolling release, that all of the updates would reach the same point... but looking at it now, with what I have learned, I think I see more how this works. So, I wonder... maybe I SHOULD reinstall?! and make sure I am on the stable all the way. If there is not a simple (but thorough) way to sync everything so that it is on STABLE, that might be the best course. (I am still not 100% on all of this, but I am getting closer. ) BTW you said as long as I copy etc and home to an EXT4 partitioned drive? Does that have something to do with file pointers, etc?

Home partition
On the plan for home being a separate partition... YES! PLEASE!
In fact, I have read about that and tried to do it, but the process got very confusing and I thought after reading several helps on it, that I woudl just stick to the auto.
If you have a definitive guide you can recommend, I woudl appreciate that. After seeing so many different points about it, I was too uncomfortable to go "winging" it!

NOTE: I wish Manjaro and others would give a similar automated selection to use the whole drive but make home a separate partition, since I have seen this subject in so many threads. Choices now are "Auto" and "YOU WILL DESTROY EVERYTHING AND START SKYNET"!

Timeshift works well, (I think) but it does not allow BU's to network drives, so that stinks!
Filezilla seems thorough, but also seems to want to restore everything, whether it was part of a problem or not. I mentioned RSYNC only because it was a choice between that and B-something in TS, and that choice seemed less helpful.

Thank you @AgentS.

Great responses. I will go read and come back. If you have observations based on any new info from this post, please advise.


So If I understand you correctly you are looking for information on manually partitioning manjaro with a separate home partition?

Yes sir!
If "manually" doing it, is documented in a way that I can follow, I certainly want to do that myself. But so far, the how-to's I went through did NOT match what I saw on the screen and after so many steps I felt they must be for other environments.

I may be more comfortable with them now, after going through several things now, but 35+ years of Microsoft means I don't know what I don't know.

Do you have one you think lines up pretty well with the newest Manjaro install? Please do point me to it.

If you were asking about my NOTE, then No. I hope, especially with so many new folks flocking to Linux from Windows, that the Live Install routines would provide for another more automated selection:

  1. Use the whole disk
  2. Use the whole disk but separate the /home into its own partition
  3. Manual

I just mention this because SO MANY posts have argued that the separation of /home to a separate partition is a good idea.

Just thoughts.

Reading, and attempting to comply.

inxi -Fxxxza --no-host
System:    Kernel: 5.2.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=c07076d8-5e11-43e1-9d62-1afc277124df rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 audit=0 
           Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: SABERTOOTH 990FX R2.0 v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 2901 date: 05/04/2016 
Battery:   Device-1: hidpp_battery_0 model: Logitech K800 serial: <filter> charge: 70% (should be ignored) rechargeable: yes 
           status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 2S serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 8-Core model: AMD FX-9370 bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 2 stepping: N/A 
           microcode: 6000852 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76317 
           Speed: 2734 MHz min/max: N/A Core speeds (MHz): 1: 2734 2: 4332 3: 4032 4: 4168 5: 2706 6: 4548 7: 3203 8: 4209 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition] vendor: XFX Pine driver: radeon 
           v: kernel bus ID: 07:00.0 chip ID: 1002:6818 
           Display: x11 server: X.Org 1.20.5 driver: radeon FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: AMD PITCAIRN (DRM 2.50.0 5.2.14-1-MANJARO LLVM 8.0.1) v: 4.5 Mesa 19.1.6 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series] vendor: XFX Pine 
           driver: snd_hda_intel v: kernel bus ID: 07:00.1 chip ID: 1002:aab0 
           Device-3: Logitech HD Webcam C615 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-4:2 chip ID: 046d:082c 
           serial: <filter> 
           Sound Server: ALSA v: k5.2.14-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k v: kernel port: c000 bus ID: 09:00.0 
           chip ID: 168c:0030 
           IF: wlp9s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK P8 series driver: r8169 v: kernel 
           port: b000 bus ID: 0a:00.0 chip ID: 10ec:8168 
           IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 254.51 GiB (12.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 2B6Q scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: SSD 840 Series size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 8B0Q scheme: MBR 
           ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 3B6Q scheme: GPT 
           ID-4: /dev/sdd vendor: Seagate model: ST3250823AS size: 232.88 GiB block size: physical: 512 B logical: 512 B 
           speed: 1.5 Gb/s serial: <filter> rev: 3.03 scheme: MBR 
Partition: ID-1: / raw size: 465.46 GiB size: 457.16 GiB (98.22%) used: 254.51 GiB (55.7%) fs: ext4 dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 28.8 C mobo: N/A gpu: radeon temp: 43 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 251 Uptime: 4h 57m Memory: 15.56 GiB used: 3.25 GiB (20.9%) Init: systemd v: 243 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36

Have you read the Manjaro Guide or any Tutorials on installation?

I completely agree with that!

1 Like

Well it is deceivingly simple actually. You really don't need a guide.
This is for UEFI installation. You have newer hardware so it is probably the best choice. This also assumes you understand the basics of bios set up like disabling secure boot.
Set the drive up as GPT.
Partition 1:
512 Mib (linux uses Mib not MB that you can look up but they are not drastically different: enter 512 for the size) formatted as Fat32 mounted at /boot/efi You must select the boot and efi flags. Just check the bubbles/boxes.
Partition 2:
32 Gib (again not the same as GB enter 32750 for the size ) formatted ext4 mounted at / (NOT the same as /root!)
Partition 3:
Rest of the drive (it will do this automatically no need to enter a number for size here) formatted as ext4 mounted at /home.
That's pretty much it. This way all games/personal files are on home so if you reinstall and or restore a timeshift snapshot you just ignore /home and reinstall/restore the rest i.e. ( / ).

Edit: almost forgot swap is up to you if you want one. You have 16 Gb of ram so probably not needed unless you run virtual machines.
P.S. This is why you were asked to post the out put you did. i could not have made these suggestions not knowing the specifics of you hardware.


Then run in terminal

sudo pacman-mirrors -naRS stable
sudo pacman-mirrors -i
# Select the 10 fastest mirrors from the list
sudo pacman -Syyuu

For a new (re)installation, only backup (simple copy on an ext4 partition) /home and /etc.
After installation, restore data to your new home place and keep /etc/ only for reference, in case you need to check/compare with new settings.

1 Like


Have you read the Manjaro Guide or any Tutorials on installation?

Yes. I have. But note what I said before... I didn't understand a lot of what I was seeing.... so, since you ask this, maybe it is time for me to go back and scan it again!

Now see.... First I laughed and then cried!

Well it is deceivingly simple actually. You really don't need a guide.

...How long have you been doing this in your sleep?

Saying it does not make it so.

assumes you understand the basics of bios set up like disabling secure boot.

What I used to think were basics, have come back to bite me. secure boot is something I do remember reading about. I went through and looked and dealt with it, I guess. So many different CMOS, SETUPs, BOOT configurations make it hard to understand if you do not spend your work life going into them.

I do know I don't like to encrypt things, so I usually keep this sort of thing off. I will check the next time I am in the setup and make sure it is off. But I am 99% sure I read about that and made it what was suggested.

Set the drive up as GPT.

Short statement but I had not heard of THIS until you said it.
And since I am trying to wean from Windows in work, I had kept the old drives in this machine. I am getting to the point where I started to feel more comfortable on Linux, so at some point I should remove them.

Partition setup:
I was so with you until we hit

mounted at / (NOT the same as /root!)

I had read that / was root. And if this is NOT root, then where is it, because it is not /home. Right?

Does root become .... NVM! I am just completely guessing now!

I had read that I really shouldn't need a swap area due to the ram AND the fact that I am on an SSD. True?

I am going to go to STABLE following @AgentS and continue to read the homework she assigned.

I am part way through and STILL don't understand how to copy from the tty into the GUI side where the browser is.
The Link says how to format it, etc., once I paste it, but the commands like dmsg and systemctl show me things on the tty screen...
OK. I will just ask... Is it as simple as selecting and copying in the tty, and that will be buffered until I get to a working GUI where I can paste out?!
No! That can't be it! Well, for one thing. Thinking it through I realize I don't know how to select multiple lines in the tty without a mouse!

OK! Well maybe my question/statements will allow you to see where I am getting hung up!

BTW @AgentS I see mention in the comments below the content of the first link, that people didn't know about gist. I looked back to see what they were talking about and didn't find it, but I will read on, once I get through the most necessary stuff here!

...and when I BU, I am taking

( /var/cache/pacman/pkg )

just because you dared me to try! Hehehehe.

Keep reading :hugs:. You will see the differences between / and /root. I only mentioned it because you need to use / and there are two different selections when setting up partitions. / and /root.


See what I mean! I don't know what I don't know.

At one point not long ago, I was so proud that I was starting to understand that / was root.

Now you have smashed me to the floor!

I will keep reading, since I do believe I am going to have to re-install not long from now.

Right after "not knowing what you don't know" comes "not knowing what you did!" and it leaves the OS .... weakly-configured.

Thanx for making note on the / versus /root. I will look.

So, is it a consensus that I should try to go to STABLE, then reboot... but go into CMOS/SETUP on the way to make sure I am set to SECURE BOOT OFF.... then see it is boots?

I will. BUT, if it doesn't, and I start diagnosing in tty2, how do I get that tty2 screen stuff into a post here, on the GUI side of things? I read the first link. Maybe it is in another training course, but I am hoping you can tell me simple since I feel like I am missing something.


Well, you have to realize there is a cost if you want to grow up be a System Administrator. Even for Windows, if you ever had installed it yourself, you would know a lot of those needed for a Linux installation.
So, if you really want to "be the boss" of your computer, you have to go slowly, study, ask questions and try things. There is a lot of good info in Manjaro Wiki and Manjaro Forum Tutorials, also topics with questions you want to ask. Go slowly, go forward!
But don't expect a line-by-line explanation of everything in a topic. This is against thee Forum Rules and unrespectful to the rest of the forum users.

Everything you want to ask has been answered (in the past). It shouldn't be answered over and over again, don't you agree?

1 Like

I was a System Admin. Looong ago. I don't think I am really up to that now. I work on other things.

I say mostly, because although I have found many descriptions of things, and how to do them, things are changing so fast that I often cannot match up the way it WAS, and the how-to based on that, and the NEW which is the current iteration.

That is NOT to mean I think someone should redo it for me. I am just saying, at my age it does become more difficult especially with so many options.

So, I hope you are happy you have helped me. I doubt it was a waste of anyone's time as I will help someone else here or in other ways.

I have installed Thousands of Windows OSes... DB's... etc. etc. No. This is not a matter of not studying or being lazy. It is a matter of remembering and pulling all of the new study back into something that makes sense.

As far as against forum rules, I guess you mean that this thread has wandered? I regret that. I was hoping help for me might be help for others, too!

I am still stuck with booting into an Emergency status.
I will try to take the steps you have suggested and then maybe go the reinstall route, unless you have other suggestion.

Whether you do or do not, please know you are respected and anything that came across otherwise was a lack of good communication on my part. Sorry about that for sure.


In the How to provide good information in your posts link...

I have now read it 3 times, just to make sure I didn't obviously miss how to do it, but it does not seem to be there.

In the section for Non-booting sort of errors
It goes into how to get to tty2 and the commands to use, with options, but at the end of the section it SKIPS how to copy what those commands give on the screen, into the GUI.

It says:

What to do with the error you find?

Now that you have this information post the critical things using the code tags in the forum software depicted with the </> symbol in the post editor toolbar.

... but is the process to just write everything down?
That post was written to show how to look and diagnose but I think many times a new Linux user will need to get those results into a post for assistance, rather then them knowing what the lines mean.

Maybe when you run these commands from tty2 the results are concatenated into a logfile somewhere which can be accessed later, once in GUI?

Maybe there is some sort of redirect process one can use to send the info to a place that is available once graphically booted?

I ask because it seems like there is an expectation that this should be obvious, and I am OBVIOUSLY missing how to do it.


Forum kindly sponsored by