You are in Emergency mode (How to leave and stay out of the ER)

Yes sir!
If "manually" doing it, is documented in a way that I can follow, I certainly want to do that myself. But so far, the how-to's I went through did NOT match what I saw on the screen and after so many steps I felt they must be for other environments.

I may be more comfortable with them now, after going through several things now, but 35+ years of Microsoft means I don't know what I don't know.

Do you have one you think lines up pretty well with the newest Manjaro install? Please do point me to it.

If you were asking about my NOTE, then No. I hope, especially with so many new folks flocking to Linux from Windows, that the Live Install routines would provide for another more automated selection:

  1. Use the whole disk
  2. Use the whole disk but separate the /home into its own partition
  3. Manual

I just mention this because SO MANY posts have argued that the separation of /home to a separate partition is a good idea.

Just thoughts.

@AgentS
Reading, and attempting to comply.


inxi -Fxxxza --no-host
System:    Kernel: 5.2.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=c07076d8-5e11-43e1-9d62-1afc277124df rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 audit=0 
           Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: SABERTOOTH 990FX R2.0 v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 2901 date: 05/04/2016 
Battery:   Device-1: hidpp_battery_0 model: Logitech K800 serial: <filter> charge: 70% (should be ignored) rechargeable: yes 
           status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 2S serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 8-Core model: AMD FX-9370 bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 2 stepping: N/A 
           microcode: 6000852 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76317 
           Speed: 2734 MHz min/max: N/A Core speeds (MHz): 1: 2734 2: 4332 3: 4032 4: 4168 5: 2706 6: 4548 7: 3203 8: 4209 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition] vendor: XFX Pine driver: radeon 
           v: kernel bus ID: 07:00.0 chip ID: 1002:6818 
           Display: x11 server: X.Org 1.20.5 driver: radeon FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: AMD PITCAIRN (DRM 2.50.0 5.2.14-1-MANJARO LLVM 8.0.1) v: 4.5 Mesa 19.1.6 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series] vendor: XFX Pine 
           driver: snd_hda_intel v: kernel bus ID: 07:00.1 chip ID: 1002:aab0 
           Device-3: Logitech HD Webcam C615 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-4:2 chip ID: 046d:082c 
           serial: <filter> 
           Sound Server: ALSA v: k5.2.14-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k v: kernel port: c000 bus ID: 09:00.0 
           chip ID: 168c:0030 
           IF: wlp9s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK P8 series driver: r8169 v: kernel 
           port: b000 bus ID: 0a:00.0 chip ID: 10ec:8168 
           IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 254.51 GiB (12.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 2B6Q scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: SSD 840 Series size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 8B0Q scheme: MBR 
           ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 3B6Q scheme: GPT 
           ID-4: /dev/sdd vendor: Seagate model: ST3250823AS size: 232.88 GiB block size: physical: 512 B logical: 512 B 
           speed: 1.5 Gb/s serial: <filter> rev: 3.03 scheme: MBR 
Partition: ID-1: / raw size: 465.46 GiB size: 457.16 GiB (98.22%) used: 254.51 GiB (55.7%) fs: ext4 dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 28.8 C mobo: N/A gpu: radeon temp: 43 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 251 Uptime: 4h 57m Memory: 15.56 GiB used: 3.25 GiB (20.9%) Init: systemd v: 243 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36

Have you read the Manjaro Guide or any Tutorials on installation?

I completely agree with that!

1 Like

Well it is deceivingly simple actually. You really don't need a guide.
This is for UEFI installation. You have newer hardware so it is probably the best choice. This also assumes you understand the basics of bios set up like disabling secure boot.
Set the drive up as GPT.
Partition 1:
512 Mib (linux uses Mib not MB that you can look up but they are not drastically different: enter 512 for the size) formatted as Fat32 mounted at /boot/efi You must select the boot and efi flags. Just check the bubbles/boxes.
Partition 2:
32 Gib (again not the same as GB enter 32750 for the size ) formatted ext4 mounted at / (NOT the same as /root!)
Partition 3:
Rest of the drive (it will do this automatically no need to enter a number for size here) formatted as ext4 mounted at /home.
That's pretty much it. This way all games/personal files are on home so if you reinstall and or restore a timeshift snapshot you just ignore /home and reinstall/restore the rest i.e. ( / ).

Edit: almost forgot swap is up to you if you want one. You have 16 Gb of ram so probably not needed unless you run virtual machines.
P.S. This is why you were asked to post the out put you did. i could not have made these suggestions not knowing the specifics of you hardware.

3 Likes

Then run in terminal

sudo pacman-mirrors -naRS stable
sudo pacman-mirrors -i
# Select the 10 fastest mirrors from the list
sudo pacman -Syyuu

For a new (re)installation, only backup (simple copy on an ext4 partition) /home and /etc.
After installation, restore data to your new home place and keep /etc/ only for reference, in case you need to check/compare with new settings.

1 Like

@AgentS

Have you read the Manjaro Guide or any Tutorials on installation?

Yes. I have. But note what I said before... I didn't understand a lot of what I was seeing.... so, since you ask this, maybe it is time for me to go back and scan it again!

@anon20763909
Now see.... First I laughed and then cried!

Well it is deceivingly simple actually. You really don't need a guide.

...How long have you been doing this in your sleep?

Saying it does not make it so.

assumes you understand the basics of bios set up like disabling secure boot.

What I used to think were basics, have come back to bite me. secure boot is something I do remember reading about. I went through and looked and dealt with it, I guess. So many different CMOS, SETUPs, BOOT configurations make it hard to understand if you do not spend your work life going into them.

I do know I don't like to encrypt things, so I usually keep this sort of thing off. I will check the next time I am in the setup and make sure it is off. But I am 99% sure I read about that and made it what was suggested.

Set the drive up as GPT.

Short statement but I had not heard of THIS until you said it.
And since I am trying to wean from Windows in work, I had kept the old drives in this machine. I am getting to the point where I started to feel more comfortable on Linux, so at some point I should remove them.

Partition setup:
I was so with you until we hit

mounted at / (NOT the same as /root!)

I had read that / was root. And if this is NOT root, then where is it, because it is not /home. Right?

Does root become .... NVM! I am just completely guessing now!

SWAP
I had read that I really shouldn't need a swap area due to the ram AND the fact that I am on an SSD. True?

So!
I am going to go to STABLE following @AgentS and continue to read the homework she assigned.

I am part way through and STILL don't understand how to copy from the tty into the GUI side where the browser is.
The Link says how to format it, etc., once I paste it, but the commands like dmsg and systemctl show me things on the tty screen...
OK. I will just ask... Is it as simple as selecting and copying in the tty, and that will be buffered until I get to a working GUI where I can paste out?!
No! That can't be it! Well, for one thing. Thinking it through I realize I don't know how to select multiple lines in the tty without a mouse!

OK! Well maybe my question/statements will allow you to see where I am getting hung up!

BTW @AgentS I see mention in the comments below the content of the first link, that people didn't know about gist. I looked back to see what they were talking about and didn't find it, but I will read on, once I get through the most necessary stuff here!

@AgentS
...and when I BU, I am taking

( /var/cache/pacman/pkg )

just because you dared me to try! Hehehehe.

Keep reading :hugs:. You will see the differences between / and /root. I only mentioned it because you need to use / and there are two different selections when setting up partitions. / and /root.

Argh!

See what I mean! I don't know what I don't know.

At one point not long ago, I was so proud that I was starting to understand that / was root.

Now you have smashed me to the floor!

I will keep reading, since I do believe I am going to have to re-install not long from now.

Right after "not knowing what you don't know" comes "not knowing what you did!" and it leaves the OS .... weakly-configured.

Thanx for making note on the / versus /root. I will look.

So, is it a consensus that I should try to go to STABLE, then reboot... but go into CMOS/SETUP on the way to make sure I am set to SECURE BOOT OFF.... then see it is boots?

I will. BUT, if it doesn't, and I start diagnosing in tty2, how do I get that tty2 screen stuff into a post here, on the GUI side of things? I read the first link. Maybe it is in another training course, but I am hoping you can tell me simple since I feel like I am missing something.

Thanx!

Well, you have to realize there is a cost if you want to grow up be a System Administrator. Even for Windows, if you ever had installed it yourself, you would know a lot of those needed for a Linux installation.
So, if you really want to "be the boss" of your computer, you have to go slowly, study, ask questions and try things. There is a lot of good info in Manjaro Wiki and Manjaro Forum Tutorials, also topics with questions you want to ask. Go slowly, go forward!
But don't expect a line-by-line explanation of everything in a topic. This is against thee Forum Rules and unrespectful to the rest of the forum users.

Everything you want to ask has been answered (in the past). It shouldn't be answered over and over again, don't you agree?

1 Like

Mostly.
I was a System Admin. Looong ago. I don't think I am really up to that now. I work on other things.

I say mostly, because although I have found many descriptions of things, and how to do them, things are changing so fast that I often cannot match up the way it WAS, and the how-to based on that, and the NEW which is the current iteration.

That is NOT to mean I think someone should redo it for me. I am just saying, at my age it does become more difficult especially with so many options.

So, I hope you are happy you have helped me. I doubt it was a waste of anyone's time as I will help someone else here or in other ways.

I have installed Thousands of Windows OSes... DB's... etc. etc. No. This is not a matter of not studying or being lazy. It is a matter of remembering and pulling all of the new study back into something that makes sense.

As far as against forum rules, I guess you mean that this thread has wandered? I regret that. I was hoping help for me might be help for others, too!

I am still stuck with booting into an Emergency status.
I will try to take the steps you have suggested and then maybe go the reinstall route, unless you have other suggestion.

Whether you do or do not, please know you are respected and anything that came across otherwise was a lack of good communication on my part. Sorry about that for sure.

2 Likes

@AgentS
In the How to provide good information in your posts link...

I have now read it 3 times, just to make sure I didn't obviously miss how to do it, but it does not seem to be there.

In the section for Non-booting sort of errors
It goes into how to get to tty2 and the commands to use, with options, but at the end of the section it SKIPS how to copy what those commands give on the screen, into the GUI.

It says:

What to do with the error you find?

Now that you have this information post the critical things using the code tags in the forum software depicted with the </> symbol in the post editor toolbar.

... but is the process to just write everything down?
That post was written to show how to look and diagnose but I think many times a new Linux user will need to get those results into a post for assistance, rather then them knowing what the lines mean.

Maybe when you run these commands from tty2 the results are concatenated into a logfile somewhere which can be accessed later, once in GUI?

Maybe there is some sort of redirect process one can use to send the info to a place that is available once graphically booted?

I ask because it seems like there is an expectation that this should be obvious, and I am OBVIOUSLY missing how to do it.

Thanx!

Then we can communicate fine!

It's about "Help Vampires". If you don't know the term, DDG is your friend. (I searched it also...)

Since the beginning and also in your posted pictures (ALBUM), there are clear signs of a disk error. You should check on this first.
If the disk is new, do some low-level checks (utilities are free on Recovery Software/CDs online) and if you are lucky, you can ask a replacement on warranty.
If the disk is old, it maybe the MTBF has reached to practical EOL and you should try making a scenario for replacement, before it's too late.

If you finish with the disk problem, then we can check on other things.
BTW has this installation ever worked/booted successfully to GUI? If not, you might look for video drivers issues. But not before the disk issue.

We wait for news! :wink:

OK. I get the Help Vampires thing. It is pretty self explanatory really. I don't think I do that. In fact, I have tried to give back with each thing I have learned to do. You can probably find examples here. I have also posted many, many scripts online for others. That said, I am assuming you were not suggesting I was.

Unfortunately, (and humorously a bit!) I didn't know what DDG is your friend meant, and... well... Google is not where you want to go with that! I got some very weird stuff!

2 Likes

SpectGrab001

2nd result

Well... I searched a bit differently.

Had you said Duck Duck search, I would have known. I have used that before, but more used to Google is your friend!

I edited because the link I just posted with a picture of what I got from that search, auto expands to the picture! It looks bad. But, if you want to see why it was funny what I got, search Google for : "DDG is your friend" You will see what I saw.

Don't worry, It's not too bad, but not professional looking either.. so I deleted the picture so it wouldn't show up in the posts! But funny.

So, with all of that done.

This is my plan based on what I have learned and seen:

  1. Change to STABLE. (did that)
  2. Shut down
  3. Remove drives not needed, in case they are affecting the boot.
  4. On starting, go into the CMOS/Settings to verify SECURE BOOT OFF
  5. Continue to see if it boots without Emergency.

I am assuming that my post that the SMART check verified a low-level goodness of the drive. (I also commented that the SSD drive is brand new but has been used to install 3 OSes in the last few weeks.

If that is a good plan for now I will continue. Who knows! Maybe the move to stable will make all the difference!

...I am still reading in the background if you have any other ideas before I do that.

Thanx.

@AgentS
Found it!
It was under the Troubleshooting video cards section!

Log your troubleshooting info in a file

You should store your troubleshooting in a file, in order to later provide your troubleshooting report to your support request topic.

You can do that, appending this at the end of each command you run in TTY (use whatever file name):

| tee -a video-nvidia.log

So...
I can get into tty2. do some recon and if I see things questionable give the command, example:
sudo dmesg | grep sd | tee -a lookingForErrors.txt

...and THAT file will be created (somewhere). But I will search for it and find it after the fact.

Thanx for that. Now I have the parts for a process.

I am remembering the first time I used a redirect.... Is that the right word? (those lines "|")...

It was in a language called Rexx, on AmigaDos.

Wow! Long time ago seems.

I know! I know!

Keep reading!

Forum kindly sponsored by