Youtube freeze in full screen

Hi,

youtube freeze in full screen with firefox.
What can I do?

Let's get some more info:


Also, what addons are you using, have you changed anything in about:config?

thanks for answer !
here is my about:config:
Capture%20d%E2%80%99%C3%A9cran%20de%202019-12-15%2021-42-59

I don't think this is an issue cause it use to work on ubuntu with the same add-ons...

I don't know witch log I could display to help...

I've install: flashplugin-32.0.0.293-1
but don't solve the problem ...
I don't understand if youtube use flash or html5 or something else ??

I would suggest to note all your addons and changes and then reset firefox. Then you can add one addon at a time and verify if this addon (or combination of addons installed at that time) causes the issue. As far as I understand you have not used about:config in the address line to make config modifications in firefox itself (?)

Output of

inxi -Fxxxza --no-hostname

would still be interesting.

no, i've just installed add-ons by searching for them months ago on ubuntu and it used to work, now on manjaro these add-ons have been installed by firefox sync

[seb@sebastien-pc ~]$ inxi -Fxxxza --no-hostname
System:    Kernel: 5.3.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=4069eea0-bad6-4772-8d5a-0a167688fa8d rw quiet apparmor=1 
           security=apparmor resume=UUID=18131bc8-fde7-4349-a968-6a5f8a3f9ca4 udev.log_priority=3 
           Desktop: Gnome 3.34.1 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Intel model: NUC6i5SYB v: H81131-506 serial: <filter> UEFI: Intel 
           v: SYSKLi35.86A.0060.2017.0414.1652 date: 04/14/2017 
CPU:       Topology: Dual Core model: Intel Core i5-6260U bits: 64 type: MT MCP arch: Skylake family: 6 model-id: 4E (78) 
           stepping: 3 microcode: D6 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 14404 
           Speed: 500 MHz min/max: 400/2900 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 4: 500 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Iris Graphics 540 driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1926 
           Display: x11 server: X.org 1.20.6 driver: i915 compositor: gnome-shell resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel Iris Graphics 540 (Skylake GT3e) v: 4.5 Mesa 19.2.7 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k5.3.15-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 chip ID: 8086:1570 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 chip ID: 8086:24f3 
           IF: wlp1s0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.00 TiB used: 1.64 TiB (81.8%) 
           ID-1: /dev/sda vendor: Intel model: SSDSA2CW080G3 size: 74.53 GiB block size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s serial: <filter> rev: 0362 scheme: GPT 
           ID-2: /dev/sdb vendor: Kingston model: SM2280S3G2120G size: 111.79 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 01.R scheme: GPT 
           ID-3: /dev/sdc type: USB vendor: Samsung model: M3 Portable size: 1.82 TiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1404 scheme: MBR 
Partition: ID-1: / raw size: 46.59 GiB size: 45.61 GiB (97.89%) used: 24.95 GiB (54.7%) fs: ext4 dev: /dev/sdb2 
           ID-2: swap-1 size: 7.89 GiB used: 186.4 MiB (2.3%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 55.5 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 210 Uptime: 2d 8h 12m Memory: 7.67 GiB used: 3.43 GiB (44.8%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: gnome-terminal inxi: 3.0.37

In an Ubuntu forum, I read that the Google Translator addons did not allow the playback of YouTube video in fullscreen.

Advice:
To discard the plugins try deactivating all. Restart And try.

1 Like

That is not "about:config"
that would look more like this:

Also .. just gonna point out here that you are using a handful of poorly-designed addons. Some I would even consider malware.
I dont recognize half of them and a few seem useless, but thats for you to decide.
What I can tell you for sure is that ABP and Ghostery both are bad on performance and also track you. yay.
You might want to take another look at them .. but also disable the 'also use in safe mode' on all of them .. and then start in safe mode .. see if any addons are to blame.

Another thing to consider is that your profile itself might be damaged - you may want to try using a fresh profile.

But Youtube was working well in full screen with the same add-ons on ubuntu ...

Done ... but still some freeze in fullscreen. The freezes seems to appear after a few minutes during advertising. Is it related to a buffer issue ?

here is the begin of my about:config :
Capture%20d%E2%80%99%C3%A9cran%20de%202019-12-16%2014-49-10
Can't paste all, is there a way to display this a terminal ?

What addons do you advise to avoid advertising ?

I have deactivated all of them but still freezing in fullscreen ...

ublock:origin is usually enough, but some folks like to add privacy badger to that.

but if it still happens with them deactivated then you might want to try with a fresh profile.
You can check by using the profile manager at about:profiles or in terminal firefox -p

Just create a new profile for testing purpose and see if the freezing still happens.
(Message meant for OP, of course)

NoScript or uBlock Origin + Firefox's strict mode

I don't understand if youtube use flash or html5 or something else?

At youtube.com/html5 you could see. Well, at least in the not so distant past. Now it's nothing there.

I've tried in safe mode : same problem.

I've tried using a new profile with "firefox -P" from a terminal. Although it seems to occur less often, freezes still happen sometimes when i go from windowed to full screen. Strange thing, if I take a screenshot during freeze, youtube video goes on and the screenshot is normal.

During freeze, it is just the image that freeze while sound keeps going on.

I also have these errors log in terminal :

[seb@sebastien-pc ~]$ firefox -P
[Child 13560, MediaDecoderStateMachine #1] WARNING: Decoder=7f6ec56e9c00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-71.0/dom/media/MediaDecoderStateMachine.cpp, line 3308
[Child 13560, MediaDecoderStateMachine #1] WARNING: Decoder=7f6ec56e9c00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-71.0/dom/media/MediaDecoderStateMachine.cpp, line 3308

Install this add-on https://addons.mozilla.org/en-US/firefox/addon/enhanced-h264ify/ in your test profile and try blocking VP8 and VP9. Who knows...
BTW, use

$ firefox --ProfileManager --no-remote

to create a new profile, then to launch it.

Also worth checking these things:

https://wiki.archlinux.org/index.php/Hardware_video_acceleration#Intel

https://wiki.archlinux.org/index.php/Firefox/Tweaks#Enable_OpenGL_Off-Main-Thread_Compositing_(OMTC)

1 Like

What I did was to remove video-linux in Manjaro Settings Manager ==> Hardware Configuration and restart. After that I had no freezing

Been attempting to fix this issue in various ways (turning on/off hardware acceleration and etc). But issue appeared only in Firefox.

I turned off all add-ons -- youtube stopped freezing. So with some tips in this topic, I turned off Google translate plugin and full screan glitch completely went away.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by